divs jump around when clicking their scrollbar arrows

VERIFIED FIXED

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: myk, Assigned: Eric Vaughan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Overview Description: 

In a page with a series of DIV elements that have overflow: auto; and float:
left; style settings, clicking scrollbar arrows on the DIV elements causes the
elements to jump around, disappear, and reappear.

Steps to Reproduce: 

1) Load the test case that will be attached.
2) Click the down arrow on the leftmost DIVs scrollbar.
3) Watch the fireworks.

Actual Results: 

The right most two DIVs disappear and the left DIV moves downward.

Expected Results: 

The DIV content scrolls up.

Build Date & Platform Bug Found: 

Linux 2000-02-14-09

Additional Builds and Platforms Tested On: 

none

Additional Information: 

Clicking on where the scrollbars for the other DIV elements were produces more
interesting effects (elements reappear and disappear alternately, etc.).

Could be related to bug 28090 which I just filed on a similar test case (I was
experiencing both problems on the actual page I am working on).  That bug was
filed under compositor because the DIVs were in the correct location, just not
drawn correctly.  This bug is filed under layout because the DIVs move around.

Enabling viewmanager2 does not fix this bug.
(Reporter)

Comment 1

18 years ago
Created attachment 5344 [details]
test case

Comment 2

18 years ago
Eric, there are a couple of issues here

As far as things moving around, that's because the block code doesn't do a 
particularly good job of computing where the floater will be in advance or 
reflowing it, and so it ends up moving it twice and things flicker. I already 
have bug #22684 for that problem

The other issue is the fact that clicking on the scrollbar causes a reflow. I 
really think we need to fix this, so we don't do a reflow.

Maybe in an ideal world that would be okay, but with the way things work today 
it just isn't efficient
Assignee: troy → evaughan
(Assignee)

Comment 3

18 years ago
This is now fixed the example does not jump. 

As for reflowing this is because of the style rules for buttons. This will 
actually happen with html buttons as well. Its because their content areas move 
when clicked on. This affect is achieved by removing right and bottom padding 
and adding it to the top and left when depressed. The style system thinks a 
reflow is needed, which my be true because the content area could have view and 
that view my need to be repositioned. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 4

18 years ago
Fixed in the Feb 29th build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.