Right clicking on tool bar and clicking "Open in tabs" when you have one site (and as such no tabs) visible resets original tab to Mozilla start page

VERIFIED DUPLICATE of bug 216346

Status

()

Firefox
Tabbed Browser
VERIFIED DUPLICATE of bug 216346
14 years ago
14 years ago

People

(Reporter: mj535_uk, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0

When I first load Mozilla, I get directed to my chosen homepage.  At the current
time, there are no tabs visible.  When I right-click on the tab browser bar and
click "Open in tabs", a new tab opens.  The problem is the tab containing the
original site (i.e. the homepage or any site you're looking at in that tab)
automatically gets reset to the "Firefox - Rediscover the webs" start page. 
This is extremely annoying as  you then have to click Back to regain viewing of
what you were looking at.

When I have clicked "Open in tabs", the right-click option changes to "New tab",
and there are no further problems.

Reproducible: Always

Steps to Reproduce:
1.Start Mozilla, and the homepage will load.
2.When the homepage has loaded, and there are no other tabs open, right click on
the row where the tabs usually appear, and click "Open in tabs"
3.

Actual Results:  
A new tab opens (there are now two).  What is now the first tab (the original
containing the homepage) has now changed to the "Firefox - Rediscover the web"
start page, and is no longer what you were originally looking at.  The new tab
opens automatically to "Mozilla Firefox - Live Bookmarks"

Expected Results:  
The software should have left the original tab showing the original page as
chosen by the user, and not automatically reset to the "Firefox - Rediscover the
web" start page.

Running Firefox 1.0 on Windows XP Home Edition SP2
The browser does not crash.

Comment 1

14 years ago
You probably mean "Open in Tabs" option in Bookmarks Toolbar context menu. It
*replaces* the current set of tabs. That is by design.

*** This bug has been marked as a duplicate of 216346 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Right, it appears you were confusing the tab bar with the bookmarks toolbar,
which on a default install is above the tab bar. You can hide it by right
clicking the File menu and unselecting "Bookmarks Toolbar", or move it by
selecting "Customize" from that same menu.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.