paper size for printing should be smarter recognised

RESOLVED DUPLICATE of bug 144625

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 144625
14 years ago
12 years ago

People

(Reporter: bjoern, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041109 Firefox/1.0

the default paper size is letter, which results in broken ps printouts if the
printer  is a A4 printer. Most users don't know that the wrong paper size is the
reason for those broken printouts. I suggest to make the page size default a bit
smarter.
If there is no default in the prefs.js file, mozilla apps should ask the cups
server for the selected printer for its page size and if cups is not used it
should default to the paper size which can be retreived from the locale via a
nl_langinfo(...) call. 

Reproducible: Always

Steps to Reproduce:

Updated

14 years ago
Summary: paper size for printing should be smarter recogniced → paper size for printing should be smarter recognised

Comment 1

13 years ago
Also occurs on Windows 2000.
And I wouldn't see this as an enhancement, it's a bug (although not a major one).

Comment 2

13 years ago
happens also on WindowsXP. Would be nice if it can be fixed because somme
LaserPrinters issue errors when printing LETTER if standard is A4 for example.

Comment 3

12 years ago
This bug was filed for Linux. Printing in Windows is a seperate issue.

*** This bug has been marked as a duplicate of 144625 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.