Persistence of new email popup notification is not configurable

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
14 years ago
14 years ago

People

(Reporter: fabian, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: 

Version: Thunderbird 1.0 (20041206)
Platform: All (verified under Windows XP Home, Windows XP Professional and
Ubuntu Linux)

When the popup of new notification mail appears in tray bar, it is visible for
only a few seconds (less than 3 I think). It would be very useful to have this
delay being configurable for increased accessibility, even be able to set it
permanently visible when new email exists, for people with motion and/or
coordination problems. It would also increase usability for other users.

I am filing this as "normal" because I think it's an important usability problem
that should be fixed.

Reproducible: Always

Steps to Reproduce:
1. Check the box in Tools > Options > General > When new messages arrive > Show
an alert (this is checked by default)
2. Reduce the delay of automatic email notification in Account Setting >
(exiting account) > Server Settings > Check for new messages every [ ] minutes
3. Send a new message to self
4. Wait for the delay setup, email notification tray popup should appear briefly

Actual Results:  
Email notification pops-up briefly, not long enough for anyone that takes more
than 2-3 seconds to navigate to it.

Expected Results:  
Email notification should pop-up for a longer period of time or even
permanently, as a configurable delay.

I searched for a while in the forums, Google, checked about:config (using the
extension in Thunderbird) and din't find anything. I think this should be
something similar to the update_notifications.enabled value, but it doesn't
exist. Can a new config value be created to control this ?

I also contacted the MozSource email support service and got this answer:

"I searched for about 30 minutes or so for an answer to your question, and
couldn't come up with anything.  Typically there is a way to change everything
in Thunderbird, even if it's hidden, but I checked every possible setting I
could find, and found nothing.  I checked the deepest darkest recesses of the
preferences, places I'm not comfortable dabbling in, and still didn't find a
setting to change the delay on the notification.

The only things I found were how to turn off the notification and how to make it
play a sound or wav file when new mail arrives, all of which is readily
available from "Tools" then "Options". 

This leads me to believe that either I'm completely missing where the
information is or the delay is hard coded into the browser and can't be changed
without a rewrite.

Thank you,

Lee, on behalf of the MozSource Support Team "

Comment 1

14 years ago
(In reply to comment #0)
> I am filing this as "normal" because I think it's an important usability
> problem that should be fixed.

This is incorrect.  "Normal" applies to something that is not working as 
intended.  If it's working as intended, but not as you want, that is an 
enhancement request.

Since you are using Linux, you don't have the advantage of the system-tray icon 
found in Windows and Mac, which persists until the user takes some action.  
There is another RFE specifically for overcoming this shortcoming in Linux: see 
bug 137462.
Severity: normal → enhancement
(Reporter)

Comment 2

14 years ago
Apologies for the wrong Linux mention. I mixed two different bug reports. OS
should then be Windows.

I maintain it's a normal bug, not a RFE, as it should be a configurable delay,
and it does NOT persist until action is taken - did you reproduce it ? The
intended (current) behavior is a problem for people with disability problems as
described. This is a usability problem.

This is no related to bug 137462, an unfixed Mail & News bug filed almost 3
years ago about new email *icon* notification not showing at all, as opposed to
*tray sliding popup* showing too briefly and not being configurable.
Severity: enhancement → normal
OS: All → Windows XP

Comment 3

14 years ago
(In reply to comment #2)
> I maintain it's a normal bug, not a RFE, as it should be a configurable delay,
> and it does NOT persist until action is taken

You are wrong, for the reason cited in comment 1.
  https://bugzilla.mozilla.org/page.cgi?id=fields.html#bug_severity
Your saying it "should be configurable" does not qualify as a specification.  

> The intended (current) behavior is a problem for people with disability
> problems as described. This is a usability problem.

The usability problems are minor.  The presence of the icon in the tray is 
sufficient to indicate that there is new mail; the icon has a tooltip which 
displays (some of) the information from the alert when the mouse hovers over it; 
and the information displayed in the alert is actually inaccurate in certain 
situations anyway.

Are you aware of *any* other program that allows such alerts to have 
configurable persistence?

Do not change this bug's severity back.
Severity: normal → enhancement
OS: Windows XP → All
Summary: Delay of new email popup notification is not configurable → Persistence of new email popup notification is not configurable
Version: unspecified → Trunk
(Reporter)

Comment 4

14 years ago
I don't appreciate personal threats to close my BMO account and insults to my
email account. Perhaps you think that's how I'll be convinced I should think
like you, that this is not a problem when in fact it is for me and several
people I've moved to TB. Quoting:

"

Received: from [64.61.211.39] (modem0039-cp-tnt-mpls2.cpinternet.com [64.61.211.39])
	by mail.cpinternet.com (8.12.10/8.12.10) with ESMTP id j15GGavW012045
	for <magicfab@gmail.com>; Sat, 5 Feb 2005 10:16:36 -0600 (CST)
Message-ID: <4204F1BE.10200@well.com>
Date: Sat, 05 Feb 2005 10:18:06 -0600
From: Mike Cowperthwaite <mcow@well.com>

"Did [I] reproduce it"?  What kind of question is that?  Of *course* I have
"reproduced" the fact that there is no setting for this window.

I did not, and do not, deny that this feature is not in place.  What I SAID, and
what you had DAMN WELL BETTER HEAR THIS TIME, is that you are requesting a
feature.  There is no bug -- the program is working as intended.  Period.

Do not change the bug's severity back.  Reversing decisions made by people who
have been given the responsibility to make such changes is not acceptable, and
repeated incidents may result in your losing your Bugzilla account."

You should relax and think before writing things like that. I have no clue who
you are, even though you must think I should. DO NOT WRITE DIRECTLY TO ME AGAIN.

Respectfully requesting anyone with the right permissions to mark this as
WONTFIX, I'll find a workaround elsewhere.

Comment 5

14 years ago
=> Wontfix per reporter's comment 4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 6

14 years ago
It turns out this is configurable already, using a hidden preference:
  user_pref("alerts.totalOpenTime", 7000);     <- means "7 seconds"

Apparently the Preferential extension provides a UI for this:
  http://preferential.mozdev.org/preferences.html
(Reporter)

Comment 7

14 years ago
Thank you, I appreciate you researching this even though it was supposed to be a
"WONTFIX".
You need to log in before you can comment on or make changes to this bug.