Firefox Update window takes over entire browser. Clicking Cancel closes completely closes Firefox.

VERIFIED DUPLICATE of bug 278759

Status

()

Toolkit
Application Update
--
major
VERIFIED DUPLICATE of bug 278759
13 years ago
10 years ago

People

(Reporter: Chris Tashjian, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050204 Firefox/1.0+ (bangbang023)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050204 Firefox/1.0+ (bangbang023)

When clikcing the New Updates Available icon the "Mozilla Firefox" window
becomes "Firefox Update".  You can not get back to your browsing session (no
matter how many tabs are open).  Clicking "Cancel" completely closes Firefox.

I've tried this with a completely clean/new profile and only 1 extension
(adblock) installed (so that I could trigger the update icon).

This also happens with 20050203 Firefox/1.0+ (bangbang023), not sure about
builds prior to that.

This is NOT a duplicate of 257789

Reproducible: Always

Steps to Reproduce:
1. Install Firefox and setup a completely new profile
2. Install an older version of some extension so that the automatic update will
be triggered
3. Click the "Update(s) Available" icon in the upper right-hand corner of the
browser.

(note that the browser window has been replaced with the Firefox Update window)

4. Click "Cancel" or install the updates if you wish.  
Actual Results:  
Firefox closes completely, no way to return to your browsing session.

Expected Results:  
Updater pops up as a window which can be cancelled/closed independant of the
main browser window.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 257789 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
This is NOT a duplicate of 257789 as I stated in my initial report.  In 257789
the update window appears as a seperate modal window.  My bug report states that
it takes over/replaces the whole browser window.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 278759 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.