Context menu inconsistent on image

RESOLVED DUPLICATE of bug 245163

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 245163
13 years ago
12 years ago

People

(Reporter: Rob Roy, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Right clicking on a very tall image displays a short context menu when clicking
anywhere on the image before scrolling. Scroll the image down to the end and
right click again on the image produces a whole new context menu, one in which
you can finally select Save Image As...

Reproducible: Always

Steps to Reproduce:
1. Create a free login account at the specified web site and go to the page in
the URL listed in this bug report
2. Find a tall image, if the images haven't been moved around I chose the tall
dragon image in the middle of the 3rd row
3. Right click on the image and see a context menu with only 3 menu items.
4. Scroll down to the end and right click on the image again. This time a much
larger context menu appears, one in which you can choose Save Image As...

Actual Results:  
On images that you can't scroll much, you won't get the Save Image As... menu
item and therefore you can't save off the image.

Expected Results:  
All image related context menu items should appear any time you right click over
an image.

*** This bug has been marked as a duplicate of 245163 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
I don't believe this is a duplicate of 245163. That bug refers to too many menu
items in the context menu. This bug refers to not showing the correct context
menu. In one case, when you right click on a menu you only get 3 menu items.
None of which deals with the image you're clicking on, i.e. no Save Image As...
The other case shows the correct context menu with Save Image As...

Updated

12 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.