Adding a page to bookmarks fails when the page has no <title>

RESOLVED FIXED in Camino0.9

Status

RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: sfraser_bugs, Assigned: sfraser_bugs)

Tracking

unspecified
Camino0.9
PowerPC
All

Details

(URL)

(Assignee)

Description

14 years ago
If I try to bookmark a text file or somesuch, the Add Bookmark dialog throws an
error:

2005-02-04 17:10:43.234 Camino[6819] *** Assertion failure in -[NSTextFieldCell
_objectValue:forString:], AppKit.subproj/NSCell.m:1131

2005-02-04 17:10:43.335 Camino[6819] Invalid parameter not satisfying: aString
!= nil

and never comes up.
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

14 years ago
Summary: Adding a page to bookmarks files when the page has no <title> → Adding a page to bookmarks fails when the page has no <title>
whooops!
Target Milestone: --- → Camino0.9
(Assignee)

Comment 2

14 years ago
Should I use the url to fill the text box, or use "untitled"? I'd rather not
leave it empty, because that dialog has no code to disable the OK button when
the text field is empty.
i can go either way, honestly. "untitled" might be good, but what's more useful
in the menu if they don't change it?
(Assignee)

Comment 4

14 years ago
*** Bug 282147 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

14 years ago
Fix checked in; I use the url if the title is empty.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 6

14 years ago
Ugh, this looks like it's broken again. I'm getting a bunch of

2005-04-02 05:45:46.085 Camino[23634] *** Assertion failure in -[NSTextFieldCell
_objectValue:forString:], AppKit.subproj/NSCell.m:1079
2005-04-02 05:45:46.088 Camino[23634] Invalid parameter not satisfying: aString
!= nil

on pages with no <title>. Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

14 years ago
It's happening in -[AddBookmarkDialogController
showDialogWithLocationsAndTitles:isFolder:onWindow:], FWIW.
(Assignee)

Updated

14 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 8

14 years ago
Fixed again.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.