When forwarding an email, your signature appears below quoted text. This should be configurable

RESOLVED DUPLICATE of bug 273114

Status

Thunderbird
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 273114
13 years ago
9 years ago

People

(Reporter: Mike Lowell, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: version 1.0 (20041206)

Please see Bug 62429 first.

When Thundirbird is configured to automatically attach a signature and forward
messages inline, when you forward a message your signature will apear below the
inline (quoted) text of the message you're forwarding.

It's currently possible to configure Thunderbird to:
   - Automatically quote original message when REPLYING, and
   - Start my REPLY above the quote, and
   - Place my signature below my REPLY (above the quote)

All this seems to work well.  It is desirable to have this same type of
functionality when FORWARDING messages.

This functionality is desirable for all the same reasons as Bug 62429.

Reproducible: Always

Steps to Reproduce:
0. This assumes you already have signatures configured, and are forwarding
messages inline.
1. Start Thunderbird.
2. Select a message in your Inbox.
3. Press CTRL-L, or click on the "forward" button.
4. Notice that your signature is BELOW the inline quoted text.
Actual Results:  
Notice that your signature is BELOW the quoted text.

Expected Results:  
I believe it's desirable to have the same behavior when REPLYING or FORWARDING
messages, so the simplest solution would be to re-word the existing "Composition
& Addressing" preferences to talk about "Reply" and "Forward" settings at the
same time, and then change the behavior of the composer to rely on this single
set of preferences for both Forwarding and Replying -- this way a user only has
to choose their quoting/replying/signature insertion settings once.

I'm suggesting that it's not necessary to have unique quoting/replying/signature
insertion settings for REPLYING vs. FORWARDING (these should be the same).

However, I would still be plenty satisfied if a new configuration section was
added that was equivilent to the reply settings in the "Composition &
Addressing" area in the "Account Settings" menu -- i.e. just duplicate the
current settings for REPLYING, and name it FORWARDING, and make the composer
aware of these new preferences.

I've never reported a bug for Thunderbird before.  If my message is incomplete
or in some way unclear, please don't hesitate to Email me.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 273114 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.