History disappears on crash

RESOLVED DUPLICATE of bug 102519

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED DUPLICATE of bug 102519
14 years ago
10 years ago

People

(Reporter: big3al, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

1.0 Branch
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0


Firefox tells me that it has performed an illegal action & shuts down.  When it
does that, the entire History file is wiped out.  Or to put it another way, when
you go to any saved webpage in the history file, the page comes up blank.  Every
page on every day is blank !  Why does it do that ?  The info below is what I
copied from the details of the error.

- - - - - - - - - - - - - - - - - - - - - - - - - - - 

FIREFOX caused an invalid page fault in
module MSVCRT.DLL at 018f:7801020b.
Registers:
EAX=035a7544 CS=018f EIP=7801020b EFLGS=00010216
EBX=035a7f80 SS=0197 ESP=00c9f080 EBP=00c9f088
ECX=3ffe9d52 DS=0197 ESI=035ffffc FS=0fe7
EDX=00000000 ES=0197 EDI=03600000 GS=0000
Bytes at CS:EIP:
f3 a5 ff 24 95 20 03 01 78 8b c7 ba 03 00 00 00 
Stack dump:
00000002 035a2158 00c9f0b4 00600feb 035a7f84 035a7f80 fffff5c4 035a4dd0 035a2140
00000291 035a2158 00565431 035a2140 00c9f118 0056428e 035a4dd0


Reproducible: Couldn't Reproduce



Expected Results:  
Do not delete History file.

Comment 1

14 years ago
See bug 63292 or bug 102519.

Comment 2

14 years ago
marking a duplicate, nothing new here

*** This bug has been marked as a duplicate of 102519 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Version: unspecified → 1.0 Branch

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: mozilla → bookmarks
You need to log in before you can comment on or make changes to this bug.