the composition window does not disappear using WXG

RESOLVED FIXED in mozilla1.8beta1

Status

()

P1
critical
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

({inputmethod, intl, regression})

Trunk
mozilla1.8beta1
x86
Windows 2000
inputmethod, intl, regression
Points:
---
Bug Flags:
blocking1.8b -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

WXG is Japanese IME.
If a user uses WXG, the composition window is appeared. (We don't need it.)
And the composition window is not disappeared by end composition.
Therefore, the composition window is overlapped on Mozilla.

This is regression of bug 278061.
The positioning of composition window does not need process.
But I added it. It is my mistake.
Created attachment 173471 [details] [diff] [review]
Patch rv1.0
Attachment #173471 - Flags: review?(timeless)
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
Flags: blocking1.8b?
Priority: -- → P1
Target Milestone: --- → mozilla1.8beta

Comment 2

14 years ago
Comment on attachment 173471 [details] [diff] [review]
Patch rv1.0

can someone else confirm this is the right thing to do?

where would i get WXG if i wanted to try it?
Attachment #173471 - Flags: review?(timeless) → review?(timeless)

Comment 3

14 years ago
I also wanna try it in addition to testing the patch with IMEs that I currently
have.

Masayuki, a little explanation as to why you need this patch (and why it didn't
break other IMEs but broke WXG) would be nice.
Component: Internationalization → Widget: Win32
I think that the composition window appears with WXG, it is bug of WXG.
(if it is specification of WXG, the composition window should be disappeared after
end composition.)

If we don't carry over the WM_IME_* messages to DefaultWndProc, the composition
window is always disappeared with other IME. But, with WXG, if we type "悪戯",
WXG shows warning about it. In this time, WXG uses composition window. However,
if we don't position the composition window, the composition window does not
appeare.
The positioning of composition window is added by bug 278061. It is not needed
for ATOK. It is my mistake.
> can someone else confirm this is the right thing to do?

Do you need another tester?

> where would i get WXG if i wanted to try it?

WXG is not free ware.
If you need it, you have to buy the package.

Comment 6

14 years ago
Comment on attachment 173471 [details] [diff] [review]
Patch rv1.0

*sigh*, can we ask the makers of WXG to donate a couple of copies to mozilla
foundation?
Attachment #173471 - Flags: review?(timeless) → review+
Takita-san:

See comment 2, comment 5 and comment 6.
(Assignee)

Updated

14 years ago
Attachment #173471 - Flags: superreview?(bzbarsky)
Comment on attachment 173471 [details] [diff] [review]
Patch rv1.0

sr=bzbarsky, but I don't claim to have any understanding of what this is really
doing....
Attachment #173471 - Flags: superreview?(bzbarsky) → superreview+
(Assignee)

Updated

14 years ago
Attachment #173471 - Flags: approval1.8b?
the risk is low. and this bug is very important for WXG users.
Risk may be low, but it appears that the confidence level of the reviewers
matches that.

Jshin, were you at least able to verify this patch does not break our other
supported IMEs?  I'd like to not regress those to workaround what appears to be
a bug in WXG.

Comment 11

14 years ago
I've just applied the patch to my tree and tested it on Win2k. Something might
be wrong with my tree. When I switch between differnt IMEs and keyboards, the
keyboard label (either minimized at the lower-right corner or maximized and
floating) doesn't change   the keyboard/IME changes. 

Masayuki, have you seen this? Install several different IMEs (Japanese, Korean,
SC, TC) and keyboards (Russian, En-US, Greek, Hindi, French, German, etc) and
try to switch between them (by pressing alt-shift). FF 1.0 and Mozilla 1.8a6
don't have this problem. 

I backed out patches for this bug and bug 279816 and I still have the problem.
It may as well be my tree. I'll try distclean and build if you don't see this
problem. 
I cannot reproduce the problem on Nightly builds of Mozilla, Firefox1.0, trunk
of Firefox with this patch.
Often, I reproduce it.
But it is my mistake.

1. Alt(left) down.
2. Caps Lock down + up.(it is mistake)
3. Shift(left) down + up.

Comment 14

14 years ago
I wiped out my debug build (sometimes, distclean is not sufficient) and rebuilt
it only to find that it still has the problem with IME/kbd switching. I can't
reproduce the problem with the latest firefox trunk build, but mozilla.org's
mozilla suite trunk nightly (2005-02-12-05) does have the problem. This must be
a separate bug and I'll file it with you added to Cc. In the meantime, I'm
building firefox so that I can test your patch without being bothered by the
IME/kbd switching issue. 
Don't think we'll hold the beta for this fix, but once jshin is ok with the
patch, we'd probably take the fix.
Flags: blocking1.8b? → blocking1.8b-

Comment 16

14 years ago
Sorry for taking too long. The patch here doesn't regress anything (on Win 2k
and Win ME). There's something strange about IME/KBD switching on Win ME, but
that's a separate bug nothing to do with this patch.
Comment on attachment 173471 [details] [diff] [review]
Patch rv1.0

a=caillon for 1.8beta then
Attachment #173471 - Flags: approval1.8b? → approval1.8b+
jshin:

Could you check-in the patch?

Comment 19

14 years ago
landed
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Keywords: inputmethod
You need to log in before you can comment on or make changes to this bug.