sunbird crashing at startup after entering title-less remote calendar

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
14 years ago
12 years ago

People

(Reporter: jwz, Assigned: shaver)

Tracking

({crash})

Sunbird 0.2
x86
Linux
crash

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
I tried to subscribe to a remote calendar.
I pasted a webcal: URL in the url field, and left the name, etc blank
because I expected it to get that info out of the calendar itself.
It showed up in the list, then crashed.

And now it crashes at startup every time.  (Both crashes were the same):

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 2744384 (LWP 12819)]
0x086878df in crmf_encoder_out ()
(gdb) bt
#0  0x086878df in crmf_encoder_out ()
#1  0x086322a6 in nsReadingIterator<char>::advance ()
#2  0x08629cc6 in nsReadingIterator<char>::advance ()
#3  0x0862db93 in nsReadingIterator<char>::advance ()
#4  0x007ce6b1 in XPTC_InvokeByIndex ()
   from /usr/lib/sunbird-0.2/libxpcom_core.so
#5  0x08096451 in ?? ()
#6  0x08cc3078 in ?? ()
#7  0x0000001a in ?? ()
#8  0x00000003 in ?? ()
#9  0xbfffd784 in ?? ()
#10 0xbfffd844 in ?? ()
#11 0x00000000 in ?? ()

sunbird-0.2-i686-linux-gtk2+xft.tar.gz
Linux 2.6.10-1.741_FC3 #1 Thu Jan 13 16:38:22 EST 2005 i686 athlon
Gnome 2.8
(Reporter)

Comment 1

14 years ago
Ok, it's not that I left the name blank.  Typing in a name, selecting a color,
and giving it a webcal: URL gives me:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 5017664 (LWP 31933)]
0x081fd08f in nsWritingIterator<unsigned short>::advance ()
(gdb) bt
#0  0x081fd08f in nsWritingIterator<unsigned short>::advance ()
#1  0x004129c7 in g_vasprintf () from /usr/lib/libglib-2.0.so.0
#2  0x003ee7bb in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#3  0x003f0242 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#4  0x003f04ef in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#5  0x0022007e in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#6  0x081fd3f2 in nsWritingIterator<unsigned short>::advance ()
#7  0x085b539c in nsReadingIterator<char>::advance ()
#8  0x0865a3f4 in nsPrintSession::QueryInterface ()
#9  0x0807313b in ?? ()
#10 0x00000002 in ?? ()
#11 0xbffff620 in ?? ()
#12 0x0868e6e0 in _IO_stdin_used ()
#13 0x08063985 in ?? ()
#14 0x004cf524 in ?? () from /lib/libgcc_s.so.1
#15 0x08844028 in ?? ()
#16 0x000f4240 in ?? ()
#17 0x00fb9696 in __new_exitfn () from /lib/tls/libc.so.6
#18 0x0868e688 in _IO_stdin_used ()
#19 0x00000000 in ?? ()


and then at next startup, the crmf crash again.

The calendar I was trying was
webcal://www.retina.net/cgi-bin/sfgoth_clubs.ics

I tried another random calendar from http://www.icalshare.com/ ,
webcal://ical.mac.com/pedrofp/21C32Moon32Calendar.ics
and that one worked ok, so I guess it's freaking out because of
something in the sfgoth calendar.  It doesn't look wrong to me
at first glance, however.

(Reporter)

Comment 2

14 years ago
Created attachment 173504 [details]
busticated calendar

Here's a copy of the presumably-broken .ics file that causes the crash, in case
he ends up fixing it and hiding the sunbird bug.

Comment 3

14 years ago
Date/Time:      2005-02-05 21:53:27 -0800
OS Version:     10.3.7 (Build 7S215)
Report Version: 2

Command: mozilla-bin
Path:   
/Users/timeless/obj-powerpc-apple-darwin7.7.0-mac/dist/mozilla/mozilla.app/Contents/MacOS/mozilla-bin
Version: 1.8b (1.8b)
PID:     19666
Thread:  0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000080

Thread 0 Crashed:
0   libxpical.dylib          	0x0709452c icalrecur_iterator_next + 0x18
(icalrecur.c:2171)
1   libxpical.dylib          	0x0706f6f4
oeICalEventImpl::GetNextRecurrence(icaltimetype, bool*) + 0x894
(oeICalEventImpl.cpp:1130)
2   libxpical.dylib          	0x070780e4 recurCompareFunc(void const*, void
const*, void*) + 0x18c (oeICalImpl.cpp:1317)
3   libxpcom_core.dylib      	0x0021590c NS_QuickSort + 0x394
4   libxpcom_core.dylib      	0x00221a10 nsVoidArray::Sort(int (*)(void const*,
void const*, void*), void*) + 0x54
5   libxpical.dylib          	0x070782b4
oeICalImpl::GetAllEvents(nsISimpleEnumerator**) + 0xb8 (nsVoidArray.h:61)
6   libxpical.dylib          	0x0707d418
oeICalContainerImpl::GetAllEvents(nsISimpleEnumerator**) + 0xd0 (nsCOMPtr.h:830)
7   libxpcom_core.dylib      	0x00266eac _XPTC_InvokeByIndex + 0xd8
8   libxpconnect.dylib       	0x005fd05c NSGetModule + 0xbb18
9   libxpconnect.dylib       	0x00603060 NSGetModule + 0x11b1c
10  libmozjs.dylib           	0x00315220 js_Invoke + 0x6d4
11  libmozjs.dylib           	0x0031d3f0 js_Interpret + 0x7350
12  libmozjs.dylib           	0x00315264 js_Invoke + 0x718
13  libxpconnect.dylib       	0x005f8ce0 NSGetModule + 0x779c
14  libxpcom_core.dylib      	0x00266d48 PrepareAndDispatch + 0x2f4
15  libxpcom_core.dylib      	0x002676ec SharedStub + 0x70
16  libxpical.dylib          	0x070776ac oeICalImpl::SetServer(nsACString
const&) + 0x3b4 (oeICalImpl.cpp:833)
17  libxpical.dylib          	0x0707c96c
oeICalContainerImpl::AddCalendar(nsACString const&, char const*) + 0x2f8
(nsTDependentSubstring.h:59)
18  libxpcom_core.dylib      	0x00266eac _XPTC_InvokeByIndex + 0xd8
19  libxpconnect.dylib       	0x005fd05c NSGetModule + 0xbb18
20  libxpconnect.dylib       	0x00603060 NSGetModule + 0x11b1c
21  libmozjs.dylib           	0x00315220 js_Invoke + 0x6d4
22  libmozjs.dylib           	0x0031d3f0 js_Interpret + 0x7350
23  libmozjs.dylib           	0x00315264 js_Invoke + 0x718
Keywords: crash

Comment 4

13 years ago
I can't reproduce this.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050814 Mozilla
Sunbird/0.2+

Comment 5

13 years ago
0   libxpical.dylib          	0x0709452c icalrecur_iterator_next + 0x18
(icalrecur.c:2171)

libxpical no longer exists -> WFM
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

12 years ago
Status: RESOLVED → VERIFIED
Version: Sunbird 0.2RC2 → Sunbird 0.2
You need to log in before you can comment on or make changes to this bug.