Closed Bug 281217 Opened 17 years ago Closed 14 years ago

Show tasks in unifinder

Categories

(Calendar :: General, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 405508

People

(Reporter: audax321, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; chrome://navigator/locale/navigator.properties; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20050203 Mozilla Sunbird/0.2

This request is regarding the listbox that is displayed above the main schedule
component of the Sunbird application (the listbox with the options to display
ALL EVENTS, TODAY'S EVENTS, EVENTS IN THE NEXT SEVEN DAYS, etc.).

I was wondering if it would be possible to also display TASKS along with EVENTS
in this pane. If anyone has access to KDE on Linux try opening up KOrganizer and
adding events/tasks (KOrganizer calls tasks, to-do's). Notice that when a
particular day is selected the above preview listbox displays events as well as
to-do's for the selected day(s).

I think this feature could be convenient because it will display EVENTS and
TASKS together for the user. Also, if possible, to distinguish between them in
the listbox the text "EVENT:" should be added before events and the text "TASK:"
should be added before tasks. Alternatively small icons, as used in KOrganizer
could also be added.

Reproducible: Always

Steps to Reproduce:
1.Start Sunbird.
2.Add EVENTS/TASKS
3.Observe the behavior of the EVENT preview pane (listbox) above the main
schedule component of Sunbird.

Actual Results:  
Sunbird does not display both EVENTs and TASKs together the listbox.

Expected Results:  
Sunbird should display both EVENTs and TASKs in the listbox or at least allow
the option to the user.
Summary: SUNBIRD FEATURE REQUEST: Show TASKS in the EVENT PREVIEW LISTBOX at the top along with EVENTS. → Show TASKS in the EVENT PREVIEW LISTBOX at the top along with EVENTS.
IMO it's too soon to start blindly copying another application's UI for this. 
When it is established what level of task management will be provided, that is
the time to get the UI right.

The problem with displaying events and tasks together is that events have fixed
times, but in real life most tasks do not.  So displaying them intermingled is
potentially very confusing, even if you add icons as you suggest.

Unfortunately some tasks do have fixed times.  That is, they occupy time in the
calendar, but they also require action and have priority, etc.  The current
model cannot cope with these items that are both events and tasks.
QA Contact: gurganbl → sunbird
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody
OS: Linux → All
Hardware: PC → All
Summary: Show TASKS in the EVENT PREVIEW LISTBOX at the top along with EVENTS. → Show tasks in unifinder
Unifinder is also available in Lightning now.
Component: Sunbird Only → General
QA Contact: sunbird → general
Since we have a task view in lightning and there is a bug for sunbird, I think this bug can be closed.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 405508
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.