AutoTranslate does not translate this page to English

VERIFIED INVALID

Status

Core Graveyard
Tracking
P3
normal
VERIFIED INVALID
19 years ago
2 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Eric Poirier)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AUTO TRANSLATE], URL)

(Reporter)

Description

19 years ago
Steps of reproduce
1. Select menu View|Translate
2. Enter above URL and select Japanese "From" and English "To" field
3. Click on Gist button

The page is not translated to English.  It displays in Japanese.
I tested some other Japanese pages.  They are translated to English fine.

Tested 2000021608 Win32 (mozilla build), Mac and Linux commercial build.
(Reporter)

Updated

19 years ago
Group: netscapeconfidential?

Comment 1

19 years ago
Forwarded to ALIS for feedack.
Status: NEW → ASSIGNED

Comment 2

19 years ago
Note: This is a redirect issue ALIS is evaluating. Any redirected page will not 
auto-translate correctly.

Comment 3

19 years ago
What does "evaluating" mean?  Is Alis determining if they consider it a bug?
Or is Alis trying to fix it?

Comment 4

19 years ago
ALIS is trying to fix this bug. It was said to be a problem with redirects. ALIS 
told us they already fixed relative paths, but are still working on a fix for 
absolute path redirects. As the above-referenced URL does not appear to 
redirect, I've asked them to re-evaluate this bug.

Comment 5

19 years ago
According to ALIS, it's a charset alias problem charset=x-sjis...
 
"...In that version of the server, we could only specify one charset per
language (As our server was initially meant to be dedicated to a single
site, it didn't cause much problems). To support this, we have introduced
charset alias instructions and charset autodetection. The same page works
fine with our staging server ATS2.7.1b. This bug status will turn to "Solved
but to be verified by QA" with most of the others..."

Comment 6

18 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

18 years ago
I tested this in 2000041206 Win32, 2000041207 Mac, and 2000041109 and 2000041213 
Linux build.  This page is translated into English in Win32 and Mac.  However,
in 2000041109 linux build, after you click on Gist button, the page is blank.
I need to reopen this.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 8

18 years ago
Reassigned to Eric
Assignee: mcintosh → epoirier
Group: netscapeconfidential?
Status: REOPENED → NEW
(Assignee)

Comment 9

18 years ago
We tested it and it works fine with this page. The bug seems related 
specifically to the Linux build. We can rule-out the code of the View|Translate 
function in navigator.js as the problem occurs later... when clicking GIST 
button. on the home page. Now, this GIST button calls quite a few Javascript 
functions to validate the URL, etc. We will download the LINUX build and start 
to test the page. I expect to find a difference in the way the LINUX build is 
interpreting Javascript. We will do the following: 1- report on the 
Javascript lines that cause the problem 2- isolate a small test case to describe 
the bug more precisely 3- Try to change the Javascript code in the page so that 
the LINUX build can understand correctly the Javascript that it reads. 

Stay tuned for new developments... we are working on it.
Status: NEW → ASSIGNED
(Assignee)

Comment 10

18 years ago
*** Bug 35535 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
Updated to new AutoTranslate component 
Component: Internationalization → AutoTranslate

Comment 12

18 years ago
Moving to "other" Component temporarily whilst I delete AutoTranslate component 
in Bugzilla and move this to Bugsplat.

Putting on [AUTO TRANSLATE] to grab this from Other component in a bit.
Component: AutoTranslate → other
Whiteboard: [AUTO TRANSLATE]
(Reporter)

Comment 13

18 years ago
cc' ed to msanz@netscape.com.

Comment 14

18 years ago
Moved to Scopus bug id: 393784 
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 15

18 years ago
This is not Invalid bug.  This is moved to Bugscape.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.