If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[search ui] Search sidebar panel: missing 'Netscape Search' as provider

VERIFIED FIXED in M14

Status

SeaMonkey
Search
P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: german, Assigned: Robert John Churchill)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

18 years ago
From Bug Helper:
User-Agent: Mozilla/4.5 [en]C-NSCP  (Win95; I)
BuildID:    
Open Directly Search should probably named Netscape Search
Reproducible: Always
Steps to Reproduce:
1.run s search from search sidebar panel
2.pick engine
3.
Actual Results:  can't find "Netscape Search"
Expected Results:  Netscape Search should be listed (on top?)
(Assignee)

Comment 1

18 years ago
Netscape Search should NOT be listed on top.  (The list is sorted alphabetically 
and will remain that way, irregardless of what Netcenter wants.)

For Netscape, there is the "Netscape Open Directory" file.  It came from 
Netcenter named that way.

Comment 2

18 years ago
Reassigned to Mike Davis who will update the Sherlock files to fix the naming 
issues.

Also marking M14 and nominating beta 1 since the branding of "Netscape Search" 
is a business requirement.

Netcenter incorrectly named their search engine "Netscape Open Directory" in the 
Sherlock file.  They will change that to "Netscape Search" in the Sherlock file 
to fix that.

In addition to that, all the Netscape category names look terrible in the list. 
 Netcenter needs to come up with a shorter name for each of their category 
searches.  This fix is not a beta stopper, but easy to fix and is a beta 1 
polish issue.

Also, for beta 1, we have to stick to sorting alphabetically.  The only way to 
put the factory default at the top is to rename it (put a "-" or "." before the 
name).

Longer term, however, we should discuss a better sorting answer for usability 
and business reasons.  It is a better user experience for the default to be 
listed at the top.  Especially as the list of providers grows, we don't want to 
have to scroll to see the default.  Perhaps after beta 1, we can see if we can 
come up with a way for Mozilla and Commercial to define a factory default 
(others using mozilla might have it set to Yahoo or ...) and put that factory 
default at the top of the list.  I will start a separate bug on this "factory 
default comes first" need, and we can discuss it there.
Assignee: matt → mldavis
Keywords: beta1
Target Milestone: M14

Comment 3

18 years ago
Revised the Sherlock files for the fifteen Netscape Categories with renamed NAME 
attributes (to lose the "Netscape Search - " portion). 

The Sherlock file for Netscape Open Directory was renamed Netscape_Search.src 
and so was its corresponding GIF file. Inside Netscape_Search.src, the NAME 
attribute was renamed to ".Netscape Search". (I used the preceding period to 
address the alphabetization issue it being less conspicuous than the dash
character.)
(Assignee)

Comment 4

18 years ago
I won't accept the change to use a starting period to get "Netscape Search" 
first in the list. 

JOHNG:  stop suggesting changes like this.

Comment 5

18 years ago
rjc, is it that you don't want "Netscape Search" first on the list or is it that the prepended period is an ugly hack? If your problem is 
the latter, then I can suggest an invisible hack that will allow us to sort the list however we want even if the code is limited to 
sorting alphabetically. The hack only assumes that to determine alphabetical you are really using ASCII order.
(Assignee)

Comment 6

18 years ago
Claudius, the issue is that end users are going to be able to fully customize 
all these settings:  adding/renaming/deleting/sorting categories, as well as 
adding/renaming/deleting/sorting individual search engines.

Comment 7

18 years ago
Is there a way we can have it show up correctly in the Advanced tab and still
protect the sorting in the aggregated results UI?  Can we have another attribute
to sort on that is hidden taht we use within the Advanced tab?

Comment 8

18 years ago
Not clear on the status of this.  Is Netscape search on the list and we are just 
debating about Netscape being first?  Or is Netscape just on on the list.  
Please clarify.   Thanks.
(Assignee)

Comment 9

18 years ago
daver, Netscape is on the list.

In fact, (at least for beta1) for all the different search categories except for 
"Web", Netscape is currently the ONLY engine.

[A side issue, but this desperately needs to change by FCS...  hopefully 
Netcenter is working full steam on marking a lot of deals with 3rd parties so 
that we ship with a strong, solid list of useful categories, each of which has 
various popular & useful engines]
(Assignee)

Comment 10

18 years ago
Myron, I've checked in your latest set of changes.  (Two small changes: I 
removed the leading period, and I didn't rename the "Netscape Open 
Directory.src" file as it meant changing Makefiles for all platforms as well, 
and I didn't have a current build to test.  I *did* change the name inside of 
the file to be "Netscape Search" though; that's what counts in terms of what 
users see, so hopefully that's just dandy.)

I'd recommend that, post beta1, we change the names (yet again) so that they do 
have "Netscape" in them somewhere.  Its a bad precedence (we wouldn't want 
multiple files from multiple engines all using the word "Sports", for 
example)... how about putting "Netscape" after the name, such as "Sports @ 
Netscape" or "Sports - Netscape"... ?

Comment 11

18 years ago
acknowledged....makes sense to me.

Comment 12

18 years ago
Putting on PDT+ radar for beta1.  Suggest e just put space before Netscape 
Search so it shows up at the top of the list.
Whiteboard: [PDT+]

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 13

18 years ago
Is this assigned to the person that will implement the fix?  If so, when is the 
anticipated landing date?  Please put it in the status whiteboard.

Thanks,

Jim

Comment 14

18 years ago
Reassign to rjc
Assignee: mldavis → rjc
Status: ASSIGNED → NEW
(Assignee)

Comment 15

18 years ago
Marking as fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 16

18 years ago
this bug is VERIFIED fixed. with 2000022908 builds
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.