residentie.net - Site displays javascript popups saying you should use IE

RESOLVED FIXED

Status

P5
normal
RESOLVED FIXED
14 years ago
4 years ago

People

(Reporter: patrick, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

http://belkring.residentie.net displays javascript popups saying you should use
IE. It does nog seem to work with FireFox.

Reproducible: Always

Steps to Reproduce:
1. go to the site

Actual Results:  
I saw a javascript popup saying I should use MSIE.

Expected Results:  
Work with Firefox and stop whining.

Comment 1

14 years ago
There is probably an evangelism issue at:

<!-- This script and many more are available free online at -->
<!-- The JavaScript Source!! http://javascript.internet.com -->

but surely, the behaviour of your page is BY DESIGN? Unless I am
missing something, there is no bug here: Firefox is executing the
javascript embedded in the page!

Updated

14 years ago
Assignee: firefox → dutch
Component: General → Dutch
OS: Windows 2000 → All
Product: Firefox → Tech Evangelism
QA Contact: general → dutch
Hardware: PC → All
Summary: Site displays javascript popups saying you should use IE → residentie.net - Site displays javascript popups saying you should use IE
Version: 1.0 Branch → unspecified

Comment 2

14 years ago
Warning: Non-standard document.all property was used. Use W3C standard
document.getElementById() instead.
Source File: http://belkring.residentie.net/
Line: 89

Severity is not MAJOR -> NORMAL
P=P5

I can't find site info on site, but whois shows me that the contact is
info@residentienet.com

Note to webmaster: 
document.all is proprietary and ONLY for IE4. For all newer version of Internet
Explorer and any other browser after 1998 the World Wide Web consortium approved
document.GetElementById should be used.

patrick[]pine.nl can you contact the webmaster on the e-mail address above to
notify him/her of the problem?

An example contact letter can be found at:
http://www.mozilla.org/projects/tech-evangelism/site/tech-letter-nl.html

Please report your findings back here?
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5
seems to be fixed
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.