Closed Bug 281398 Opened 15 years ago Closed 11 years ago

sunbird should register "webcal:" protocol with gnome

Categories

(Calendar :: Sunbird Only, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 352566

People

(Reporter: jwz, Unassigned)

Details

When a Gnome program tries to open a webcal URL, e.g.,

  gnome-open webcal://www.dnalounge.com/calendar/dnalounge.ics

Gnome should hand that URL off to Sunbird, just as it currently
hands http: URLs off to Firefox.

Anders Carlsson says:
>
> The evolution-webcal program registers such a handler and makes it
> work with evolution. If mozilla and sunbird installed such handlers
> they would work as well.
>
> I think that firefox registers itself as the default http handler so
> the code to do that would already be there then. Just use "webcal"
> instead of "http"...
Jamie,
    I think this got fixed with bug 295896.  Can you grab a nightly build and 
confirm?
QA Contact: gurganbl → sunbird
Use this to easily import calenders from website (example: powerschool by apple
publishes calenders on teh site using the
webcal://blah.powerschool.com/blah/calender.ics)
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody
(In reply to comment #1)
> I think this got fixed with bug 295896.

No, we need to actually register as a handler for webcal:// urls, which we're not doing at the moment.

For Gnome, I think we could use gconf and simply register using a gconfschemafile.

It looks like Fx is doing it in a more hardcore fashion using C++
http://lxr.mozilla.org/mozilla/source/browser/components/shell/src/nsGNOMEShellService.cpp

I'm open to doing it a different way :)
Target Milestone: --- → Sunbird 0.5
Version: Sunbird 0.2RC2 → Trunk
Not going to make the 0.5 train.
Target Milestone: Sunbird 0.5 → ---
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 352566
No longer blocks: 352566
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.