Start page can not be set with javascript

RESOLVED INVALID

Status

()

Firefox
Preferences
RESOLVED INVALID
13 years ago
12 years ago

People

(Reporter: kh_naba, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040615 Firefox/0.9

Following javascript to set start page does not work.

<a href="http://mysite.com/#"
onClick="this.style.behavior='url(#default#homepage)';this.setHomePage('http://mysite.com/eng/');"><b>Make
Mysite your start page</b></a>


Reproducible: Always

Steps to Reproduce:

Actual Results:  
Nothing happens.

Expected Results:  
Should set the start page in preference.
There's a very good reason for this: its almost universally abused.  This is an
IE-only "innovation" that will most likely never be implemented in Mozilla core.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 2

13 years ago
Created attachment 190263 [details]
'Add to IE Bookmarks' Script

Comment 3

13 years ago
What do you think of the 'javascript:window.external.AddFavorite' command,
unique to IE, that is used to open the bookmarks window and request that you
bookmark the current page (as in 'Add To IE Bookmarks Script' attachment)?
That its abused often on less-reputable sites and that we don't want it?

Comment 5

13 years ago
(In addition to comment #3)
There is a keyboard shortcut for this in Mozilla (Ctrl + D). Couldn't people
fake the keypress and thus abuse the function?
No, we differentiate between events from trusted and untrusted content.

Comment 7

13 years ago
*** Bug 279850 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
*** Bug 345706 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
See also bug 29770, same thing for adding bookmarks from script.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.