Mozilla only starts in account which installed it Win XP SP2

RESOLVED EXPIRED

Status

Core Graveyard
Installer: GRE
--
major
RESOLVED EXPIRED
13 years ago
10 years ago

People

(Reporter: Paul, Unassigned)

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217 MultiZilla/1.5.0.4d
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217 MultiZilla/1.5.0.4d

I upgraded from 1.7.3 to 1.7.5.  I have three accounts on my system, mine & my
wife's (both administrative) and my son (limted).  After install, Mozilla won't
start in eiter my wife's or son's account, but runs fine in mine.  In their
accounts, clicking shortcut or on mozilla.exe in Program
Files\mozilla.org\Mozilla causes hourglass to appear for a few seconds, then
goes away.  Mozilla icon is grayed out.  Mozilla won't run from run window.
I uninstalled 1.7.5, re-installed 1.7.3, which previously worked from all
accounts.  It wouldn't run.  Uninstalled it, re-installed 1.7.5 - same problem.
 Uninstalled again, went to safe mode, re-installed - same problem.
When run from my wife's or son's accounts, regedit, searching mozilla entries,
finds two bad keys:
HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla
HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla.org
When first clicking on the first one, the contents show up, with error message:
Cannot open Mozilla.org.  Error while opening key.
After clicking "OK", the contents of the key are not shown.
I tried deleting the key, but get error message: cannot delete key
After uninstalling Mozilla, these keys were not there (or did not produce error
message). They re-appeared after re-install.
In my wife's account, opening Program access and Defaults, trying to set Mozilla
as default browser and e-mail client, brings up error message:
0:  Uninstall log folder not found
  HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\Mozilla\1.75(en)Uninstall\Uninstall
Log Folder

Reproducible: Always

Steps to Reproduce:
1. Uninstall Mozilla 1.7.3 (Windows XP, SP2, Athlon XP model 8, 1533.38 MHz)
2. Install Mozilla 1.7.5
3. 
Actual Results:  
Only runs from my account, will not run from other accounts on system

Expected Results:  
I have had Mozilla on this system from 0.9 on, with many upgrades.  It has
always worked fine from all accounts.  I think this is the first upgrade I've
done since installing SP2

Comment 1

13 years ago
Can you create a filemon log with a limited user? Download Filemon from
http://www.sysinternals.com/ntw2k/source/filemon.shtml. Then start up Filemon,
write in the Include field "mozilla" (without quotes, of course :), click ok.
Then try starting Mozilla. After observing that it doesn't work, save the log
with File-Save as..., zip the log and add it as Attachment to this bug here.
(Reporter)

Comment 2

13 years ago
Created attachment 175249 [details]
Filemon log of unsuccessful attempt to run Mozilla from account which was not used to install Mozilla

This is ziped log file from File mon of unsuccessful attempt to run Mozilla
from my wife's account.
(Reporter)

Comment 3

13 years ago
Created attachment 175250 [details]
Filemon log of successful attempt to run Mozilla from my account

This is ziped log file from Filemon of successful attempt to run, then close
Mozilla from my account.  Mozilla was installed from my account

Comment 4

13 years ago
It fails to locate xpcom.dll, in your account it works:
QUERY INFORMATION	C:\Program Files\Common
Files\mozilla.org\GRE\1.7.5_2004121708\xpcom.dll	SUCCESS	Attributes: A	

In the account of your wife it fails to find it (it just looks around in the
PATH and in the program folder, which doesn't work :/).
Assignee: general → gre
Component: General → Installer: GRE
Product: Mozilla Application Suite → Core
QA Contact: general
Version: unspecified → 1.7 Branch
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → EXPIRED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.