Save Page As does not save CSS-files imported from other CSS-files

VERIFIED DUPLICATE of bug 126309

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 126309
13 years ago
13 years ago

People

(Reporter: Jacob, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When doing a Save Page As on any site which first grabs a style sheet with a
<link rel="stylesheet" href="/css/home.css" type="text/css" media="screen" />
and then inside that CSS file adds @import rules to get more CSS files, only the
first CSS file gets downloaded by Firefox. This also applies to
http://digital-web.com/ (http://digital-web.com/css/home.css only contains
@import rules, as you can see, and none of them gets downloaded).

Reproducible: Always

Steps to Reproduce:
1. Visit any site with @import rules inside linked/imported CSS files.
2. File / Save Page As / (Web page, complete)
3. Open the htm-doc in your browser, or check the "<title>_files" folder.

Actual Results:  
The files @imported through the external CSS files did not get downloaded, so
many are totally stripped of their entire layout. Others just miss some elements.

Expected Results:  
Downloaded all CSS files, even if they are @imported from external CSS files
themselves.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.