can't send mail using smtp and tls

VERIFIED DUPLICATE of bug 237551

Status

--
major
VERIFIED DUPLICATE of bug 237551
14 years ago
14 years ago

People

(Reporter: drgenio, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8a6) Gecko/20050111
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8a6) Gecko/20050111

Tried to send an e-mail using gmail's SMTP service, which requires TLS. mozilla
refuses to send message and displays the following message:

"Sending of message failed. An error occured while sending mail: unable to
connect to SMTP server smtp.gmail.com via STARTTLS since he doesn't offer
STARTTLS in EHLO response. Please verify (...) settings, etc."

Tried manual testing via TELNET to port 25 and got this:

220 smtp.gmail.com ESMTP 67sm176wra
EHLO
250-smtp.gmail.com at your service
250-SIZE 20971520
250-8BITMIME
250-STARTTLS
250 ENHANCEDSTATUSCODES

Reproducible: Always

Steps to Reproduce:
1. activate POP access in GMail 
2. create new account using the option TLS (not "TLS, if available") on both
SMTP and POP3
3. try to send an e-mail mesage

Actual Results:  
Mail And News responds:

Sending of message failed. An error occured while sending mail: unable to
connect to SMTP server smtp.gmail.com via STARTTLS since he doesn't offer
STARTTLS in EHLO response. Please verify (...) settings, etc.

Expected Results:  
Send the e-mail message

Tried manual testing via TELNET to port 25 and got this:

220 smtp.gmail.com ESMTP 67sm176wra
EHLO
250-smtp.gmail.com at your service
250-SIZE 20971520
250-8BITMIME
250-STARTTLS
250 ENHANCEDSTATUSCODES

the "STARTTLS" command is there. maybe it's not recognized because it has an
hyphen and not a space after the 250

Comment 1

14 years ago
Dupe of bug 237551?
(Reporter)

Comment 2

14 years ago
sorry. missed bug 237551

*** This bug has been marked as a duplicate of 237551 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.