<form target=new> doesn't open new browser window

RESOLVED WORKSFORME

Status

()

Toolkit
Form Manager
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Peter Buck, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

<form action="lookups/index.asp" method="post" target="new">
<input type="submit">
</form>

opens page in current tab, rather than opening a new window (or new tab).  In IE
it opens a new window.

I have turned "Block Popup Windows" off but have not restarted FF (can't without
losing this bug).

Reproducible: Always

Steps to Reproduce:
1. create page with form & target page
2. open page with form
3. click on submit button

Actual Results:  
target page opens in tab which contained page with form

Expected Results:  
opened a new browser window (or tab in current window)

Comment 1

14 years ago
Works for me: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b)
Gecko/20050205 Firefox/1.0+

Try again in safe mode (no themes/extensions loaded). Or attach a testcase
showing the problem.

Comment 2

14 years ago
wfm, do you have singlewindowmode enabled?
(Reporter)

Comment 3

14 years ago
 no, I'm using the extension tabbrowser preferences (that's what you mean,
right?).  When I get a minute I'll uninstall it and try again.

Comment 4

13 years ago
(In reply to comment #3)
>  no, I'm using the extension tabbrowser preferences (that's what you mean,
> right?).  When I get a minute I'll uninstall it and try again.

Does this work if you start firefox in safe mode (disables all extensions)

Comment 5

13 years ago
I don't know what the Mozilla convention is for "matching" IE behaviour, but
according to the HTML 4.01 DTD, at

http://www.w3.org/TR/html401/interact/forms.html#h-17.3

there is no valid "target" attribute for the form element. This is the same in
the basic XHTML definitions and Strict XHTML also removes the special behaviour
for 'target="_blank"' etc. on <a> elements. Personally, I was happy to see that:
I like to choose for myself when to pop up a new window or tab...
WFM in three different builds + no response for months + extension that's done
things like that = WFM. Please reopen if you can still reproduce the bug in a
current build without TBE or TBP.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.