Manage bookmarks cannot rename first folder selected

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: jinserra, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When attempting to rename folders in manage bookmarks I cannot rename the first
folder that I click on (Rename button is currently greyed out).  I then click on
another folder and the rename button becomes available and stays that way.  This
is reproducibile every time I attempt to manage bookmarks.  If I click on a
sub-folder the rename button is still unavailable until I click on a second folder.



Reproducible: Always

Steps to Reproduce:
1.  Open manage bookmarks - rename button is currently available
2.  Left click on any folder (on the left hand menu) - rename button is unavailable
3.  Left click on any folder (on the left hand menu) - rename button is available 
4.  Left clicking on any subsequent folder the rename button is continues to be
available
Actual Results:  
rename button is currently available
rename button is unavailable
rename button is available 

If you click on a folder on the right menu the rename button becomes available,
but the first folder you click on the left side cannot be renamed.  You must
first click on another folder and then click back on the previous to rename the
folder

Expected Results:  
Any folder or bookmark that I click on should be renameable

Comment 1

14 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050818
Firefox/1.0+
Assignee: vladimir+bm → nobody

Comment 2

13 years ago
I am using Win 98 with Firefox 1.5 beta 1;
The problem has been accurately described and is reproducible.
Buttons MOVE  Property  and RENAME are enabled and disabled as a group as mentioned.

Comment 3

13 years ago
I am using "Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1" Under 10.3.9 and can reproduce this too.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks

Comment 5

12 years ago
using 2.0.0.3 on WinXP this bug still exists

Comment 6

12 years ago
I was able to reproduce this.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/2007051502 Firefox/2.0.0.4
Confirmed using Firefox 2.0.0.4 with a new profile on Windows XP SP 2. However, this WORKSFORME using the latest trunk build. Can someone else confirm that this is fixed on trunk?

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Version: unspecified → 2.0 Branch

Comment 8

12 years ago
Yes.  WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/2007060204 Minefield/3.0a6pre
Resolving as WORKSFORME based on comments 7 and 8 since we don't know what code change fixed this. You will see this fix in Firefox 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.