Closed Bug 281623 Opened 16 years ago Closed 16 years ago

dates earlier than 1900 are added one day

Categories

(Calendar :: General, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 238632

People

(Reporter: Frank.Mauche, Assigned: mostafah)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5) Gecko/20050203 Mozilla Sunbird/0.2

Whenever you'll set an event before 1900 for instance take the 08.02.1861 and
you want your calendar to remind you of that date every year, as it is an
historical event, sunbird 0.2 as well as the calendar extension for Thunderbird
(build: 2005011112-cal) will "add one day". That is to say this event which was
set for the 08.02.1861 and also set to be rembered every year will appear on the
09.02.2005. If you doubleclick this event on 09.02.2005 it will show you the
right start and endtime (08.02.1861), but nevertheless it is shown in the box of
the 9th of Febuary.

(I noticed this problem as I wanted to use sunbird/ calendar extension to
produce an historical calendar which will remind you of historical events in the
past that were important, or just are interesting you. And since I want to start
sunbird /calendar extension and been shown what happened today befor xxx years I
need the remind-function) 

Reproducible: Always

Steps to Reproduce:
1. Choose a date in 1900 or even earlier
2. set an event like 08.02.1861 (foundation of CSA)
3. set "event lasts whole day"
4. set start/beginn to 08.02.1861
5. set repeat every year
press OK/enter
Actual Results:  
event is shown one day later in current month. In this case it was shown on
09.02.2005, this is also true for the years 2004, 2003, 2002 ... til' 1999, i
haven't controlled any earlier years.

Expected Results:  
if the event is set for 8.2.1861 i want to be remered on 08.02.2005 and not on
09.02.2005
Maybe related to bug 238632, which involves erroneous calculation of leap day in
1900.
This is definitely a version of the non-millenial leap year bug.  Adding events
on Feb. 28, 1900 reproduces the problem, but events on March 1, 1900 do not. 
Request it be marked duplicate.

*** This bug has been marked as a duplicate of 238632 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.