The favicon image of the page is cached and a new favicon image is NEVER again accepted.

RESOLVED DUPLICATE of bug 240795

Status

()

--
minor
RESOLVED DUPLICATE of bug 240795
14 years ago
13 years ago

People

(Reporter: rainbowstranger, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I loaded a HTML page from my computer
file:///E:/programming/projects_dev/projects_dev_web/cyr-latin/cyr-latin.html
The favicon appeared in left of the URL at the Location bar.  After that I
replaced the "favicon_cyr-latin.ico" file with another one and refreshed the
page in the Firefox browser - the old icon was still standing there.  I cleared
all the cache from my computer using the "Tools -> Options -> Privacy" tool,
then refreshed the page again and the first icon was still standing there.  Then
I renamed my "cyr-latin.html" page, I also renamed the folder containg the
"favicon_cyr-latin.ico" file.  Even when I deleted that folder, the old icon was
still standing in left of the URL at the Location bar.  When I opened the "Page
Info" dialog -> Media tab, the correct address of the Icon image appeared
file:///E:/programming/projects_dev/projects_dev_web/cyr-latin/images/favicon_cyr-latin.ico
and a preview also (!?) but the "Save As..." button did nothing.  So shortly -
there is no way to clear that old icon image from my Firefox browser.

Reproducible: Always

Steps to Reproduce:
1. Load a HTML page from the localhost containing a favicon image.
2. Replace/rename/delete the favicon image from the harddrive.
3. Reload the HTML page.
Actual Results:  
The old favicon image was still visible in left of the URL at the Location bar.

Expected Results:  
The new favicon image should appear in left of the URL at the Location bar (if
the first was replaced with another) or no icon should appear (if the first was
deleted/renamed).

Theme: Firefox (default) 2.0.
OS: Microsoft Windows XP Professional Service Pack 2.
(Reporter)

Comment 1

14 years ago
When the Firefox 1.0 browser is closed and the HTML page is opened again, the
actual favicon image appears.

Comment 2

14 years ago
See Bug 240795 "Persistence of favicons, should they be permanent or
periodically refreshed?"

Your report may be a dup of that one; unfortunately, discussions concerning
favicons have never been particularly well organised and are currently in a 
real mess.

Conceivably, when the favicon is known to be on a local system
(http://localhost/ or file:/// ) then it could always be checked with
and IMS request. This would help web masters and web authors checking
these deplorable graphics before making a site live; but in general (IMHO)
favicons should be cached till the end of a session.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 240795 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.