Transparency issue with absolute positioning

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Richard Risemberg, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.17; Mac_PowerPC)
Build Identifier: 

I am writing a web page where I am using absolute positioning to place a small 
GIF on the (invisible) border of a DIV.  I ahve given the GIF a negative 
z-index.  This displays porperly in every browser I've tried so far (including 
Firefox for XP), but NOT in Firefox for OS X!  The GIF is invisible, unless I 
give it a positive z-index, in which case it obscures the text.  I want the 
text to sit over the GIF, which it indeed renders correctly in Safari, Explorer 
(Windows & Mac), Firefox Windows, and a recent version of Mozilla.

I can make the GIF a background image, but then it will not show past the 
border of the DIV in any browser, so I need to use z-index.  I have assigned 
backgroun: transparent or background-color: transparent various times (grasping 
at straws), but to no avail.

Because most of my clients are photographers, they tend to use Macs, so this is 
a problem.  If it didn't work in every other browser, I'd think it was me, but 
maybe it's not.

I ahve not uploaded the web page yet, so no URL, but it's a farily simple 
problem; I hope the description I gave will suffice.

Reproducible: Always

Steps to Reproduce:
1.  See details
2.
3.

Actual Results:  
See details

Expected Results:  
Displayed the GIF partly under a block of text
Please provide an example that shows the bug. 
Also try to test with the latest nightly trunk (1.8a) build.

Comment 2

13 years ago
No reply from reporter, no build id given --> invalid

Please reopen if you can reproduce with a nightly trunk build and anwer the
question in comment 1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.