Closed Bug 281813 Opened 17 years ago Closed 17 years ago

Implement automatic hyphenation

Categories

(Core :: Layout: Text and Fonts, enhancement)

enhancement
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 253317

People

(Reporter: bugmail, Unassigned)

Details

Gecko should implement an automatic hyphenation algorithm. Without it, a simple
single-column English-language web document displays fine. There are several
reasons for doing so, however, particularly when using text-align:justify.

1. A multi-columnar layout with text-align:justify often results in excessive
word spacing

2. Non-English languages (in particular German) often include words of such
length that even in a text-align:left configuration the ragged right margin is
just too ragged.

There is at least one freely available libraries that could be used to implement
this in a cross-platform manner:

LibHnj: <http://linux.tucows.com/preview/31687.html>

Also, platform-specific advanced typography systems such as those mentioned in
Bug 157967 may offer their own hyphenation functionality when they are passed
entire paragraphs to lay out.

This document
(<http://two.pairlist.net/pipermail/reportlab-users/2004-April/002876.html>)
also contains some interesting discussion of non-English hyphenation.

See also the long-standing Bug 9101 regarding soft-hyphen entity support. Note
that while supporting &shyp;s would certainly improve hyphenation, page authors
will never be likely to manually add all the soft hyphens that would be
necessary for optimum line-breaking.
Possible Dupe of 
Bug 253317 - Provide hyphenation dictionary for justified text 
or 
Bug 67715 - layout of full-justified text is sub-optimal

*** This bug has been marked as a duplicate of 253317 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
No longer depends on: 334608
You need to log in before you can comment on or make changes to this bug.