Junk moved to Junk Folder, but Junk Icon is removed

RESOLVED DUPLICATE of bug 261297

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 261297
13 years ago
12 years ago

People

(Reporter: david.dieterich, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: TB (Windows) version 1.0 (20041206)

I've got TB 1.0 set up so that when I see a Junk mail in my IMAP Inbox, I select
the message and click in the Junk column. The 'Recycle Can' icon appears briefly
and message is moved to the Junk folder.  When I select the Junk folder to see
what has accumulated, none of the messages have the 'Recycle Can' icon.  This
forces me to Select All and Mark as Junk before deleting.  Everything that ends
up in the Junk folder should be marked as Junk with the 'Recycle Can' icon. 
I've got all three Junk Mail Control Handling checkboxes checked.

Reproducible: Always

Steps to Reproduce:
1. Set up Junk Mail Controls so that all Handling options are checked and junk
is directed to the Junk folder on an IMAP server.
2. Select a message in you inbox and click on the dot in the Junk column.
>>> See the 'Recycle Can' icon appears briefly
>>> See the message disappear.  It reappears sometime later in the Junk folder.
3. Find the message in the Junk folder. 
>>> Note that the 'Recycle Can' icon is now gone.  This implies that it is no
longer considered junk.

Actual Results:  
When messages are automatically moved to the junk folder, they should remain junk.

Expected Results:  
When messages are automatically moved to the junk folder, they are stripped of
their junk status, which needs to be manually restored.

Comment 1

13 years ago
I have the same problem.
Fedora Core 3
Thunderbird version 1.0.2-1.3.2 (20050324)
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 3

12 years ago
This bug is still reproduces and has been confirmed by a second user.

Comment 4

12 years ago
Related to/duplicate of Core bug 261297?

Comment 5

12 years ago
Marking it as duplicate.

The last comment in this bug is commented on after Bug #261297 was checked into the trunk, so please reopen Bug #261297 if you are still seeing this behaviour.



*** This bug has been marked as a duplicate of 261297 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.