Popup blocker can be circumvented in all cases with the use of JS onMouseMove event

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: John Handelaar, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050128 Firefox/1.0 (Ubuntu) (Ubuntu package 1.0+dfsg.1-2ubuntu5)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050128 Firefox/1.0 (Ubuntu) (Ubuntu package 1.0+dfsg.1-2ubuntu5)

http://www.sitepoint.com  has demonstrated two ways of shorting-out the popup
blocker.  The first, where an onClick event is triggered on every single page
link is well-reported throughout this Bugzilla.

The bug reported *here* is that the code which is posted at the following URL
works at all:

http://www.sitepoint.com/forums/showthread.php?t=177087

Firefox should *not* interpret onMouseMove as a user-generated request to permit
a window.open() command.  But it does, and if the technique becomes more widely
known it willl render the popup blocker mostly useless.

Reproducible: Always

Steps to Reproduce:
1. Clear all browser cookies from *.sitepoint.com
2. Visit sitepoint.com
3. Popup appears as soon as the mouse is moved.

Actual Results:  
Opened a popup window

Expected Results:  
Should have blocked the popup
Created attachment 174017 [details]
onmousemove testcase

WFM, 1.0 and latest-nightly on WinXP, on Sitepoint (until I click) and the
testcase. Is your build broken, or is popup blocking broken on Linux?

Comment 2

13 years ago
Works for me. I visited your link and the information bar appeared saying that a
popup has been blocked. I'm using Firefox 1.0. Resolving as WFM pending
confirmation.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.