Add cc takes the user to some unrelated page

RESOLVED DUPLICATE of bug 63536

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 63536
14 years ago
14 years ago

People

(Reporter: esigra, Assigned: myk)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)
Build Identifier: 

 

Reproducible: Always

Steps to Reproduce:
1. Make a query. 
2. Click on a link to a matching bug report. 
3. Add a comment/CC to the report. 
Actual Results:  
The user is taken to some unrelated page (a different bug report). 

Expected Results:  
The same bug report should of course be shown again, with the new e-mail addres 
in the CC list. 

I have done this so many times that I know that I must go back and reload to 
see the result of my change to the bug, but it is still very annoying.

Comment 1

14 years ago
That's actually not a bug. It's the way that Bugzilla works -- it takes you to
the next bug in your list after you've modified the one you're looking at.
Severity: minor → enhancement
Summary: Add cc takes the user to some unrelated page → Option to stay on the same bug after modifying it
This behaviour is intentional. You're being taken to the next bug of your last
bug list. The idea is to give you the possibility to work through a list; the
probability that a user wishes to view the same bug again is pretty slim
compared to the probability that he has completed his work on the bug (he hit
commit, after all) and wants to continue his work on other bugs.

*** This bug has been marked as a duplicate of 63536 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Returning to original summary to avoid this class of duplicates (keeping the
word "unrelated" in the summary to be found by searches).
Summary: Option to stay on the same bug after modifying it → Add cc takes the user to some unrelated page
(Reporter)

Comment 4

14 years ago
> the probability that a user wishes to view the same bug again is pretty slim  
> compared to the probability that he has completed his work on the bug  
  
How do you know that? How do you know that the next thing a user wants to do is 
not for example to show votes for the bug or vote for it? And if you know it, 
why is there a "Back to bug..." link? 
  
> (he hit commit, after all) 
 
This only means that the user wanted to save some changes. It says nothing 
about what he wants to do next. Would you appreciate if for example oocalc 
switched to the next spreadsheat file in the home directory when saving (he 
saved it, after all)? 
 
 
> and wants to continue his work on other bugs. 
 
Maybe he wants to work on other bugs, or maybe he was only interested in that 
bug. And if he wants to work on another bug, the chanche that it is the "next" 
in the last search result list is negligible (seldom all hits of a search are 
of interest). The user might be interested in another bug in the list, or a bug 
that has be found with a modified or new search. Different users have very 
different workpatterns. 
(In reply to comment #4)
> How do you know that? How do you know that the next thing a user wants to do

I don't, in fact, know. It's based on the discussion over at bug 63536. Please
let's move over there, where there's a good solution proposed that seems to me
will fit your needs :)
You need to log in before you can comment on or make changes to this bug.