rogue horizontal line rendered below image with (0 < opacity < 1), for some combinations of font-size, position, top

RESOLVED WORKSFORME

Status

()

Core
Layout: Images
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Karl Johan Kleist, Assigned: Jim Dunn)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The provided minimal test case results in the provided screenshot.

A thin, horizontal line is rendered below the image if:

- the body has style "font-size: 76%" (but not 75 or 77)
- the paragraph containing the image has style "position: relative"
  and "top: 3em" (or 4em, or 5em; but not e.g. 2em or 6em)
- the paragraph containing the image has other "opacity" than 0 or 1

Could this be related to bug 274591 ?



Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
Created attachment 174057 [details]
minimal test case
(Reporter)

Comment 2

13 years ago
Created attachment 174058 [details]
screendump showing rogue horizontal line below image
Please test a current trunk build...  You're using a layout engine from early
April 2004...
(Reporter)

Comment 4

13 years ago
Created attachment 174065 [details]
minimal testcase

new testcase referring to correct bug id
Attachment #174057 - Attachment is obsolete: true
(Reporter)

Comment 5

13 years ago
Created attachment 174066 [details]
screendump showing rogue horizontal line below image

new screendump referring to correct bug id
Attachment #174058 - Attachment is obsolete: true
(Reporter)

Comment 6

13 years ago
[Sorry for spamming you all... ]

Boris, thanks for your point. I have now tried this build:

"Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050211
Firefox/1.0+" downloaded from here:

<http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-1.0+.en-US.win32.installer.exe>.

And yes, I can still reproduce the weirdness (which smells rounding error,
doesn't it?).

Comment 7

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b) Gecko/20050211

I´m seeing this too. When I switch to another tab and return, the underline may
be reduced to two points just there where the vertical borders of the image
would cut the line. I opened composer on that testpage and saw it too in
composer. I saw some changes working, and then it wasn´t reproducable.
I duplicated the <image ..> and saw two images, each one having its underline.
I minimized composer and dragged it to top left corner, then dragged the lower
right edge up and down, hovering over the testcase image in Mozilla.
The underline was sometimes destroyed, sometimes repainted, depending maybe on
speed or some other timing. I then noticed the first (original) image in the
composer window has lost its underline, the image to the right still had it.

Comment 8

13 years ago
*** Bug 286190 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
Confirming as a valid bug. Looks strange indeed and the problem seems to be very
specific.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

12 years ago
This bug is non-existent on branch Build ID: 2006011112, i'm guessing it's been fixed on trunk by now?

Comment 11

12 years ago
WFM in Windows Firefox 1.5 and 20060520 Trunk (cairo).
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.