Single quotes in email adresses are not accepted and are not listed as special characters in the error message displayed

RESOLVED DUPLICATE of bug 279016

Status

()

Bugzilla
User Accounts
RESOLVED DUPLICATE of bug 279016
13 years ago
12 years ago

People

(Reporter: Ravenous Bugblatter Beast, Unassigned)

Tracking

2.19.2
x86
Windows Server 2003

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

If you try and create a user account containing a single quote character (') it
fails with a message that it is not a valid email address. If you do this from
the public 'Create Account' page rather than the admin pages the error message
is more detailed and reads:

The e-mail address you entered (test'test@test.com) didn't pass our syntax
checking for a legal email address. A legal address must contain exactly one
'@', and at least one '.' after the @. It must also not contain any of these
special characters: \ ( ) & < > , ; : " [ ], or any whitespace.

As you can see the single quote isn't mentioned as a banned character.

This may be a regression as it appears to have been fixed in bug 165221. Bug
203795 may also be related but seems to be for more extreme deviations from
common email addresses that are still RFC 822 compliant.

Even if you do not intend to support ' characters in email addressses, the error
message should be updated to include it as a special character.


Reproducible: Always

Steps to Reproduce:
1. Click add user on the admin menu
2. Enter a user name test'test@test.com
3. Press OK

Actual Results:  
An error message that the address is invalid

Expected Results:  
Created the user
(Reporter)

Updated

13 years ago
Version: 2.19.1 → 2.19.2

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 279016 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.