bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Calendar fails or cannot load previous calendars if profile's drive changes

RESOLVED DUPLICATE of bug 232043

Status

Calendar
General
RESOLVED DUPLICATE of bug 232043
14 years ago
12 years ago

People

(Reporter: Matt, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Let's say, for instance, that we are using Portable Firefox on a USB jumpdrive.
 Now, depending on the computer used, the drive letter may change.  PFF tried to
fix dependencies on using the OS's profile rather than a specifically used
profile via the runline options.  However, Calendar still has some issues
regarding this.
For example, if we create a new calendar while the jumpdrive is mounted as the
F:, the calendar will only be loaded if the calendar is accessed while the
jumpdrive is F: and no others.  This also is a problem when installing Calendar.
 If you install Calendar to Firefox while it is mounted as F:, Calendar won't
work (error message) if the jumpdrive is mounted as any other letter (e.g. E: or
G:).  Thus, Calendar must be reinstalled with each drive letter fluctuation.

Reproducible: Always

Steps to Reproduce:
1. Using a custom profile (or PortableFirefox), install the Calendar extension
2. Make some edits to your calendar for it to save
3. Exit and restart Firefox while mounted on another letter drive
4. Attempt to open Calendar

Actual Results:  
Either an error message regarding a chrome file, or if reinstalled, an error
saying it could not find the calendar on the original drive letter rather than
the relative drive it's on.

Expected Results:  
Calendar should not depend on where the profile is stored or what drive letter
Firefox is mounted on.  Calendar and saved calendars should work perfectly fine
despite any drive letter fluctuations.

Bug found using PortableFirefox, would most likely be worse or the same when
tried using a normal build of Firefox with a custom runtime profile option.

*** This bug has been marked as a duplicate of 232043 ***
Severity: blocker → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.