fails to start and gives no error message if ~/.mozilla is not writable

RESOLVED DUPLICATE of bug 246724

Status

()

Toolkit
Startup and Profile System
--
minor
RESOLVED DUPLICATE of bug 246724
14 years ago
10 years ago

People

(Reporter: Aaron Voisine, Assigned: Benjamin Smedberg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.5) Gecko/20050211 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.5) Gecko/20050211 Firefox/1.0

If ~/.mozilla is not writable, firefox exits immediately with no error message.
I took me days to figure out what the hell was going on. I finally had to
compile it myself with debugging symbols and load it into gdb to figure it out.
A simple error message would have saved me days of frustration.

Reproducible: Always

Steps to Reproduce:
1. mkdir ~/.mozilla
2. sudo chown root:wheel ~/.mozilla
3. firefox

Actual Results:  
exit status 1, no with no output

Expected Results:  
exit status 1 with "~/.mozilla not writable" printed on stderr
(Assignee)

Comment 1

14 years ago
Did you already have a Firefox profile or not? Is this basically a request for
better error reporting?

Since you loaded it into GDB, where did the failure occur? I'm not sure that we
really intend to support readonly profiles, though it might be nice for
specialized situations such as products shipped on a CD with a pre-built "profile".
(Reporter)

Comment 2

14 years ago
No firefox profile, just an empty ~/.mozilla directory that is not writable.
Sorry I don't have the debug version anymore. I figured it wouldn't be too hard
to find. I think the problem is in xpcom/io/nsAppFileLocationProvider.cpp but
yesterday was the first time I looked at the code so I'm not really sure.

Comment 3

14 years ago
See Bug 279934 "Firefox can only be started by root and not user" which may be 
another Dup of whatever this is.

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 134903 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 246724 ***

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

13 years ago
*** This bug has been marked as a duplicate of 246724 ***

*** This bug has been marked as a duplicate of 246724 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.