build mozilla products for X11 on Mac?

RESOLVED INVALID

Status

()

Firefox
Build Config
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Joe Corneli, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Lynx/2.8.4rel.1 libwww-FM/2.14 SSL-MM/1.4.1 OpenSSL/0.9.7d
Build Identifier: fink.sourceforge.net

Actually, this is a documentation bug in all the aps.  How
am I supposed to build a version of the aps that runs under X11
on Mac OS X?  It isn't clear to me.  Emacs, by contrast, has
easy configuration options --with-x and --without-carbon.  I can't find
such options for Mozilla applications.  I know it is possible to configure
mozilla applications this way, because Fink does it.  But how??

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
should go under documentation

Comment 2

13 years ago
To build against X11, you need to specify one of the X11 toolkits (using
--enable-default-toolkit).  See
http://www.mozilla.org/build/configure-build.html for further details.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Firefox already exists in the X11 version via Fink
<http://fink.sourceforge.net/pdb/package.php/firefox>
You need to log in before you can comment on or make changes to this bug.