Cannot create an email filter on X-Original-To

RESOLVED DUPLICATE of bug 275558

Status

RESOLVED DUPLICATE of bug 275558
14 years ago
14 years ago

People

(Reporter: mozilla06b, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Thunderbird version 1.0 (20041206

Often email arrives with a dummy recipient in the To: field. Sometimes these are
legitimate lists of undisclosed email addresses. The X-Original-To contains the
actual email address of the recipient on the list. SPAMMERS use this to get by
filtering on To:

When I add a custom field of X-Original-To to filter on and create a filter, the
filter is not enabled. When I try to enable it, Thunderbird says, "This filter
was probably created by future version of mozilla/netscape. You cannot enable
this filter because we don't know how to apply it."

Filters need to be able to be created on all valid email header information.

Reproducible: Always

Steps to Reproduce:
1. Create a filter on X-Original-To
2. Sometimes it appears to be enabled when created.
3. Close the filter windows.
4. Reopen the filter window. The enable box is not checked.
5. Try to check the box. The message will appear.

Actual Results:  
Thunderbird says, "This filter was probably created by future version of
mozilla/netscape. You cannot enable this filter because we don't know how to
apply it."

Expected Results:  
Filters need to be able to be created on all valid email header information. The
filter should be enabled and run.

Comment 1

14 years ago
fixed in 1.7.6

*** This bug has been marked as a duplicate of 275558 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

14 years ago
How can this be a dup of a Mozilla core bug? I thought Thunderbird was a
seperate product? If Thunderbird is a seperate product, then this is not a dup
of 275558. If Thunderbird is part of the Mozilla core, then that needs to be
pointed out on the bugzilla page for Mozilla products and bug 275558 needs to
have the OS changed from Windows 2000 to All since this bug is filed against Linux.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
The core component is for exactly that, Core mozilla code that is shared across
products.

*** This bug has been marked as a duplicate of 275558 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.