With xcompmgr running (X composite extension manager), autoscroll results in rendering errors on pages that do NOT contain iframes.

RESOLVED FIXED

Status

()

--
trivial
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: dorrin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

755 bytes, application/zip
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When using a version of the X.org X server (and possibly Xephyr) with the X
composite extension enabled, running "xcompmgr" with any arguments can result in
rendering errors when using the autoscroll feature. This only occurs on pages
not containing iframes and on images. If the page contains the <iframe>
directive anywhere on it, the error does not occur.

Reproducible: Always

Steps to Reproduce:
1. Run a recent version of a Composite-enabled X server
2. Run xcompmgr
3. Use Firefox's autoscrolling feature on a page that contains no iframes

Actual Results:  
"Ghosting" of the autoscroll overlay image.

Expected Results:  
Not ghost the autoscroll image.

I was unable to test this bug with Mozilla, since the autoscroll extension would
not install.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 2

13 years ago
I am still getting this bug on Deer Park 2. Again, if I included an <iframe> in
the page through Greasemonkey (or saving the page to harddisk and editing the
source), the problem disappeared.
(Reporter)

Comment 3

13 years ago
Created attachment 198070 [details]
Test cases

This zipfile contains a page with the bug, and a page without the bug
(broken.html and notbroken.html, respectively).

Comment 4

13 years ago
I can confirm this bug - when I enable composite in my xorg.conf I experience this bug and it works fine if I disable it.

Comment 6

12 years ago
I see the same.

Note that the xorg people seem to think that this is a firefox bug. Also
https://bugzilla.mozilla.org/show_bug.cgi?id=355745 seems to suggest the same. IMHO, that is a dupplicate of this bug.

Comment 7

12 years ago
Confirmed.

My System setup is:
1.  Gentoo Linux 2006.1
2.  Gnome Desktop Environment 2.16.1
3.  Beryl 0.2 beta composite window manager
4.  Firefox version Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20070115 BonEcho/2.0.0.1

Steps I took to produce this bug:
1.  System started with aforementioned software running.
2.  In firefox, visit http://developer.gnome.org/doc/API/2.0/glib/index.html
3.  Scroll down, then scroll back up.  The pink header will "ghost" across the page obscuring sections of the webpage.

Steps I took to work around this bug:
1.  Terminate Beryl composite window manger.
2.  Start Metacity window manager (no composite manager)
3.  Revisit webpage from previous step #2 and scrolling works without the "ghosting".
Assignee: bross2 → nobody
Component: General → General
Product: Firefox → Core
QA Contact: general → general

Comment 8

12 years ago
This happens on my system too...

Gecko/20070601 Ubuntu/7.10 (gutsy) Firefox/2.0.0.4

For an example:

http://developer.gnome.org/doc/API/2.0/gtk/GtkWindow.html

scroll upward will give the ghost result

Comment 9

12 years ago
Is this a duplicate of #263686?

Comment 10

12 years ago
this bug has been raised countless times, here's what the devs from freedesktop suggest, 
http://lists.freedesktop.org/archives/compiz/2007-June/002344.html

besides the bug I opened, all the devs started blaming nvidia in a childish way,

..."This is an nvidia bug and their are blame us for their incompetence"...

if disabling the autoscroll is the best option yet, why not whiping out the autoscroll entirely.??

Maybe switching the format of the autoscroll images to another one that supports transparencies. PNG?

Comment 11

12 years ago
It definitely isn't (only) an NVidia bug because it happens on ATI cards too. What format are the attachments on that page supposed to be? They just appear as unidentifiable binary stuff.

Comment 12

12 years ago
hi thanks a lot for your answer, you can open that attachments with a text editor, (not quite sure what you meant with unidentiable binary stuff).
That's a workaround only for the GNOME/desktop, that sets proper window types and sizes, it's done through the gconf-editor, but it's still doesn't solves the lagging/artifacts of the autoscrolling icon itself, while it does suffice for other odd bugs.
I've been following up the threads over there on FF, which are very frequent.
I'm quite sure if someone takes on from here and investigates/asks over freedesktop,  you'll do them like a favor.
Now I'm thinking myself to start on YAW!!...(yet another workaround)

Updated

11 years ago
Duplicate of this bug: 368029

Comment 14

11 years ago
This bug has been fixed in 3.0, where the autoscroll image was moved out of the DOM (see bug #242621).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Depends on: 242621

Updated

9 years ago
You need to log in before you can comment on or make changes to this bug.