If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

leaving site cause crash if JS is disabled [dxmasf.dll + 0xd25e (0x6c4fd25e) 36bb3e10]

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
--
critical
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: R.K.Aa., Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---
Bug Flags:
blocking1.8b2 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
going anywhere else after visiting http://pub.tv2.no/nettavisen/ seems to cause
a crash.
You may have to have the page cached to be able to reproduce. I've crashed
reliably 15 times now, by simply visiting the page and clicking a link or going
to some unrelated page from my bookmarks

This started after i installed the Mozilla trunk build from Feb 11th.
Also happens in the build from the 12th. (Both on WinXP)
But my previouis build was "old" - from Jan 15, since later builds i've tested
have had other major problems.

I have JS and Java disabled, and don't use flash plugin.

The funny thing is that i can actually go on using the browser as long as I
don't dismiss the Microsoft-crash-feedback dialogue.
(Reporter)

Comment 1

13 years ago
adding to summary:
Turns out that the crash only happens if Javascript is disabled for the browser.
Summary: leaving site cause crash [dxmasf.dll + 0xd25e (0x6c4fd25e) 36bb3e10] → leaving site cause crash if JS is disabloed [dxmasf.dll + 0xd25e (0x6c4fd25e) 36bb3e10]
(Reporter)

Updated

13 years ago
Summary: leaving site cause crash if JS is disabloed [dxmasf.dll + 0xd25e (0x6c4fd25e) 36bb3e10] → leaving site cause crash if JS is disabled [dxmasf.dll + 0xd25e (0x6c4fd25e) 36bb3e10]
(Reporter)

Updated

13 years ago
Flags: blocking1.8b2?

Comment 2

13 years ago
the reason you can still use the browser is that the item crashed on a thread
and windows (and beos) is perfectly happy to let the app continue as long as the
main threads are still happy (and for plugin like stuff which runs in its own
thread, that should be for a while).
Created attachment 174317 [details]
Testcase

It seems to have something to do with the mediaplayer-embed in that page.
This is maybe related to bug 243859.

Updated

13 years ago
Component: General → Plug-ins
Keywords: testcase
Product: Mozilla Application Suite → Core

Comment 4

13 years ago
(In reply to comment #3)
> Created an attachment (id=174317) [edit]
> Testcase
> 
> It seems to have something to do with the mediaplayer-embed in that page.
> This is maybe related to bug 243859.

Your testcase rulez ;-)

I crashed the same nasty way I crashed firsttime looking at that bug yesterday,
i.e. DocWatson comming up, and when I closed DocWatson, Mozilla didn´t close.
This time, I also had procexp.exe running, process explorer from
sysinternals.com. It couldn´t kill the surviving parts of mozilla! When I
right-clicked to kill mozilla, I got asked if I want to kill Mozilla, and on
acknowledge, the cursor moved up, but the mozilla process was still running.
Ctrl-Alt-Del didn´t work, I had to use the reset button.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b) Gecko/20050214
(Reporter)

Comment 5

13 years ago
with todays build i randomly crash in dxmasf.dll even if js is enabled, by
simply clicking folders on personal toolbar
TB3966009X, TB3969129E
(Reporter)

Comment 6

13 years ago
and each time i try to drag the bookmark proxy to a folder on personal toolbar
(Reporter)

Comment 7

13 years ago
also after the drag/drop crasher was backed out: TB4016854M
(Reporter)

Comment 8

13 years ago
TB4103060H 
crashed again today. The browser was open but i didnt use it - i was starting
media player with a DVD. Mozilla then crashed. MS media player appeared to start
playing the dvd, but the display area was black, i could only hear the sound.
Shortly after it started to hang and had to be killed. Task manager showed two
running instances og mediaplayer. I was only aware of the one i had started to
play the dvd with.
With a debug build, I get this message before I crash:
Program received signal SIGSEGV, Segmentation fault.
0x5f7c21ce in unuse_netscape_plugin_Plugin ()
   from /cygdrive/c/Program Files/Windows Media Player/npdsplay.dll

Updated

13 years ago
Flags: blocking1.8b2? → blocking1.8b2-
WFM with js on and off

FF trunk Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008021504 
and
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008020803 SeaMonkey/2.0a1pre
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

10 years ago
WFM now.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030902 SeaMonkey/2.0a1pre
You need to log in before you can comment on or make changes to this bug.