Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 28216 - drag and drop hangs X server?
: drag and drop hangs X server?
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Message Display (show other bugs)
: Trunk
: x86 Linux
: P3 critical (vote)
: M15
Assigned To: Christopher Blizzard (:blizzard)
: lchiang
Depends on:
  Show dependency treegraph
Reported: 2000-02-17 11:01 PST by (not reading, please use instead)
Modified: 2004-11-22 17:25 PST (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---


Description (not reading, please use instead) 2000-02-17 11:01:33 PST

Comment 1 (not reading, please use instead) 2000-02-17 11:02:32 PST
damn, what happened to all my text!


try dragging and dropping a mail message to a mail folder.

rh 6.1, running gnome.  working on getting a stack trace now.
Comment 2 (not reading, please use instead) 2000-02-17 11:10:38 PST
this may not be an xserver hang.

but, I tried this:

click on a message, don't release the click until you are over the folder (it
doesn't seem to move the message) but it doesn't hang and the pointer returns
from a drag and drop pointer to the normal one.

now, try this:

click on a message, start a drag an drop, and let go of the button when you are
still over the thread page.  the pointer never returns to a normal pointer until
I quit mozilla, and that is hard to do in that state.

I think esther has seen this too.
Comment 3 (not reading, please use instead) 2000-02-17 11:15:11 PST
hmm, you have to work at getting this to happen.

sometimes a drag and drop (back on to the thread pane) doesn't cause the
problem, some times it does.

it took me a few tries to get into that nasty state.
Comment 4 Richard Zach 2000-02-17 11:25:34 PST
I've seen that too, but couldn't figure out how to reproduce it.
Comment 5 Christopher Blizzard (:blizzard) 2000-02-17 11:32:48 PST
Yep, that looks like my bug.
Comment 6 lchiang 2000-02-17 14:50:30 PST
I'm nominating for beta1 since this is a pretty bad system hang.
Comment 7 Phil Peterson 2000-02-17 17:32:18 PST
PDT+ since it sounds serious. rickg wonders if this is a Gnome bug we won't be 
able to fix.
Comment 8 (not reading, please use instead) 2000-02-17 17:36:02 PST
I mentioned gnome so that blizzard would know what wm I was using.

It may not matter.
Comment 9 Christopher Blizzard (:blizzard) 2000-02-17 19:33:14 PST
It doesn't have anything to do with gnome.  ( We're not linking with gnome. )
I'm pretty sure I can guess where it would happen in the code.  I've seen it
happen before.
Comment 10 Richard Zach 2000-02-19 22:29:14 PST
I can now consistently reproduce this by selecting a message, and then click,
drag, and let go of another message within the time it takes to load and display
the first message.  When the message is loaded I have the right-angle cursor and
can't bring another window to the foreground or alt-tab away from Mozilla.  This
on Linux build 2000.02.19.09.
Comment 11 leger 2000-02-23 16:05:55 PST
Putting on PDT- radar, will relnote for beta1.  lchiang, please add text for 
this relnote to:
Comment 12 lchiang 2000-02-23 16:12:36 PST
this is pretty bad and can be done accidentally. It locks up the entire system!
Comment 13 Alec Flett 2000-02-23 16:34:45 PST
removing PDT- so PDT can reevaluate.. this is critical, and as lisa said in the
last comment, this locks up the entire system, not just seamonkey.
Comment 14 Richard Zach 2000-02-23 18:40:28 PST
This doesn't hang the X server--if I switch to virtual terminal using Ctrl-Alt-1
and do "killall -9 mozilla-bin", everything's back to normal.  What happens is
that you can get yourself in a state where Mozilla thinks you're holding down
the mouse button when you're actually not.  And in the middle of a drag-and-drop
operation, you also can't Alt-Tab to another window.  Somewhere the MouseUp
event gets lost.  Maybe this is an event handling problem?  Has anyone tried my
Rx from 2-19 on Windows or Mac?
Comment 15 leger 2000-02-23 18:48:04 PST
Linux folks would know what they are doing.  Please put text for relnote 
workaround in
Comment 16 leger 2000-02-24 16:50:54 PST
Moving [PDT-] from Summary to Status Whiteboard
Comment 17 (not reading, please use instead) 2000-02-25 09:12:20 PST
this is a nasty bug, as others have stated.  is d&d working in other places
(like bookmarks?) on linux?

if not, could we stop the bug for beta by turning off d&d on linux?
Comment 18 Stuart Parmenter 2000-02-26 02:24:39 PST
I have a fix.  trying to hunt down someone to approve.
Comment 19 Christopher Blizzard (:blizzard) 2000-02-26 09:36:34 PST
I can review.  What's the fix?
Comment 20 Stuart Parmenter 2000-02-27 00:03:54 PST
fix checked in... blizzard - this is a brute force fix and could be fixed in a
better way i'm sure.
Comment 21 Christopher Blizzard (:blizzard) 2000-02-27 13:09:02 PST
This isn't the proper way to fix this.  I'm leaving it assigned to me to fix the
right way.
Comment 22 Christopher Blizzard (:blizzard) 2000-02-27 13:09:57 PST
Reassigning to me...
Comment 23 Christopher Blizzard (:blizzard) 2000-02-27 22:12:44 PST
Ok, a real fix for this has been checked in.
Comment 24 Richard Zach 2000-02-28 18:26:17 PST
I tried and tried and couldn't get it to hang. So I'm marking it verified.
Comment 25 Richard Zach 2000-02-28 18:26:55 PST
...on Linux build 2000.02.28.08
Comment 26 Christopher Blizzard (:blizzard) 2000-04-17 11:12:13 PDT
Please ignore the spam.  Changing address.
Comment 27 Christopher Blizzard (:blizzard) 2000-04-17 13:38:10 PDT
bustage from my reassign
Comment 28 Christopher Blizzard (:blizzard) 2000-04-17 13:38:32 PDT
bustage from my reassign

Note You need to log in before you can comment on or make changes to this bug.