drag and drop hangs X server?

VERIFIED FIXED in M15

Status

SeaMonkey
MailNews: Message Display
P3
critical
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
damn, what happened to all my text!

argh.

try dragging and dropping a mail message to a mail folder.

rh 6.1, running gnome.  working on getting a stack trace now.
this may not be an xserver hang.

but, I tried this:

click on a message, don't release the click until you are over the folder (it
doesn't seem to move the message) but it doesn't hang and the pointer returns
from a drag and drop pointer to the normal one.

now, try this:

click on a message, start a drag an drop, and let go of the button when you are
still over the thread page.  the pointer never returns to a normal pointer until
I quit mozilla, and that is hard to do in that state.

I think esther has seen this too.
hmm, you have to work at getting this to happen.

sometimes a drag and drop (back on to the thread pane) doesn't cause the
problem, some times it does.

it took me a few tries to get into that nasty state.

Comment 4

18 years ago
I've seen that too, but couldn't figure out how to reproduce it.
(Assignee)

Comment 5

18 years ago
Yep, that looks like my bug.
Status: NEW → ASSIGNED

Comment 6

18 years ago
I'm nominating for beta1 since this is a pretty bad system hang.
Severity: normal → critical
Keywords: beta1

Comment 7

18 years ago
PDT+ since it sounds serious. rickg wonders if this is a Gnome bug we won't be 
able to fix.
Whiteboard: [PDT+]
I mentioned gnome so that blizzard would know what wm I was using.

It may not matter.
(Assignee)

Comment 9

18 years ago
It doesn't have anything to do with gnome.  ( We're not linking with gnome. )
I'm pretty sure I can guess where it would happen in the code.  I've seen it
happen before.

Comment 10

18 years ago
I can now consistently reproduce this by selecting a message, and then click,
drag, and let go of another message within the time it takes to load and display
the first message.  When the message is loaded I have the right-angle cursor and
can't bring another window to the foreground or alt-tab away from Mozilla.  This
on Linux build 2000.02.19.09.

Updated

18 years ago
Whiteboard: [PDT+] → [PDT+] Blizzard unavailable until 2/28 or so due to move

Comment 11

18 years ago
Putting on PDT- radar, will relnote for beta1.  lchiang, please add text for 
this relnote to:
http://bugzilla.mozilla.org/show_bug.cgi?id=25524
Keywords: relnote
Whiteboard: [PDT+] Blizzard unavailable until 2/28 or so due to move → [PDT-] Blizzard unavailable until 2/28 or so due to move

Comment 12

18 years ago
this is pretty bad and can be done accidentally. It locks up the entire system!

Comment 13

18 years ago
removing PDT- so PDT can reevaluate.. this is critical, and as lisa said in the
last comment, this locks up the entire system, not just seamonkey.
Whiteboard: [PDT-] Blizzard unavailable until 2/28 or so due to move → Blizzard unavailable until 2/28 or so due to move

Comment 14

18 years ago
This doesn't hang the X server--if I switch to virtual terminal using Ctrl-Alt-1
and do "killall -9 mozilla-bin", everything's back to normal.  What happens is
that you can get yourself in a state where Mozilla thinks you're holding down
the mouse button when you're actually not.  And in the middle of a drag-and-drop
operation, you also can't Alt-Tab to another window.  Somewhere the MouseUp
event gets lost.  Maybe this is an event handling problem?  Has anyone tried my
Rx from 2-19 on Windows or Mac?

Comment 15

18 years ago
Linux folks would know what they are doing.  Please put text for relnote 
workaround in http://bugzilla.mozilla.org/show_bug.cgi?id=25524
Summary: drag and drop hangs X server? → [PDT-]drag and drop hangs X server?

Comment 16

18 years ago
Moving [PDT-] from Summary to Status Whiteboard
Summary: [PDT-]drag and drop hangs X server? → drag and drop hangs X server?
Whiteboard: Blizzard unavailable until 2/28 or so due to move → [PDT-]Blizzard unavailable until 2/28 or so due to move
this is a nasty bug, as others have stated.  is d&d working in other places
(like bookmarks?) on linux?

if not, could we stop the bug for beta by turning off d&d on linux?

Comment 18

18 years ago
I have a fix.  trying to hunt down someone to approve.
Assignee: blizzard → pavlov
Status: ASSIGNED → NEW
Whiteboard: [PDT-]Blizzard unavailable until 2/28 or so due to move
Target Milestone: M15
(Assignee)

Comment 19

18 years ago
I can review.  What's the fix?

Comment 20

18 years ago
fix checked in... blizzard - this is a brute force fix and could be fixed in a
better way i'm sure.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 21

18 years ago
This isn't the proper way to fix this.  I'm leaving it assigned to me to fix the
right way.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 22

18 years ago
Reassigning to me...
Assignee: pavlov → blizzard
Status: ASSIGNED → NEW
(Assignee)

Comment 23

18 years ago
Ok, a real fix for this has been checked in.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 24

18 years ago
I tried and tried and couldn't get it to hang. So I'm marking it verified.
Status: RESOLVED → VERIFIED

Comment 25

18 years ago
...on Linux build 2000.02.28.08

Updated

18 years ago
Keywords: relnote
(Assignee)

Comment 26

18 years ago
Please ignore the spam.  Changing address.
Assignee: blizzard → blizzard
Status: VERIFIED → NEW
(Assignee)

Comment 27

18 years ago
bustage from my reassign
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
(Assignee)

Comment 28

18 years ago
bustage from my reassign
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.