Enable different "ui.key.generalAccessKey preference settings for chrome and content

RESOLVED DUPLICATE of bug 340902

Status

()

Core
Keyboard: Navigation
--
enhancement
RESOLVED DUPLICATE of bug 340902
13 years ago
12 years ago

People

(Reporter: Greg K., Assigned: Aaron Leventhal)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Accesskey pref is currently set to control. On Mac, however, this means chrome
keyboard combinations (such as Open, Save, and Close) that would usually use the
Command key only work when using the non-standard Control key.

brade@comcast.netin Bug 207510 said,
>The issue seems to be that there is only one pref for xul dialogs and html
>pages.  If this pref is changed to command key, the dialogs respond
>appropriately: "ui.key.generalAccessKey"

>However, changing the value of that pref would impact html web pages with
>accesskeys so it is not a reasonable option.  Instead, we need a separate pref
>or use "ui.key.accelKey" and a check in nsEventStateManager::PreHandleEvent to
>know if we are in an html page or a xul dialog and use the appropriate modifier
>key.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 340902 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.