Some files are copied to Contents/Resources more than once.

RESOLVED FIXED

Status

RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: sugar.waffle, Assigned: mikepinkerton)

Tracking

Details

(Reporter)

Description

14 years ago
When the dynamic link option is enable and build is done,
the following files are copied to Camino.app/Contents/Resources
 and Camino.app/Contents/MacOS/components. 

  -- libcomposer.dylib
  -- txmgr.xpt
  -- composer.xpt

Mac OS X 10.3.8
Xcode 1.5

Log of build copied to Camino.app/Contents/Resources:

PBXCp build/Camino.app/Contents/Resources/composer.xpt
../dist/bin/components/composer.xpt
    cd /Users/sek/Documents/mozilla-current/camino/mozilla/camino
    /Developer/Tools/pbxcp -exclude .DS_Store -exclude CVS -strip-debug-symbols
-resolve-src-symlinks
/Users/sek/Documents/mozilla-current/camino/mozilla/camino/../dist/bin/components/composer.xpt
/Users/sek/Documents/mozilla-current/camino/mozilla/camino/build/Camino.app/Contents/Resources

PBXCp build/Camino.app/Contents/Resources/txmgr.xpt ../dist/bin/components/txmgr.xpt
    cd /Users/sek/Documents/mozilla-current/camino/mozilla/camino
    /Developer/Tools/pbxcp -exclude .DS_Store -exclude CVS -strip-debug-symbols
-resolve-src-symlinks
/Users/sek/Documents/mozilla-current/camino/mozilla/camino/../dist/bin/components/txmgr.xpt
/Users/sek/Documents/mozilla-current/camino/mozilla/camino/build/Camino.app/Contents/Resources

PBXCp build/Camino.app/Contents/Resources/libcomposer.dylib
../dist/lib/components/libcomposer.dylib
    cd /Users/sek/Documents/mozilla-current/camino/mozilla/camino
    /Developer/Tools/pbxcp -exclude .DS_Store -exclude CVS -strip-debug-symbols
-resolve-src-symlinks
/Users/sek/Documents/mozilla-current/camino/mozilla/camino/../dist/lib/components/libcomposer.dylib
/Users/sek/Documents/mozilla-current/camino/mozilla/camino/build/Camino.app/Contents/Resources

PBXCp build/Camino.app/Contents/Resources/English.lproj/BookmarksEditing.nib
resources/localized/English.lproj/BookmarksEditing.nib


Log of build copied to Camino.app/Contents/MacOS/components:

mino.app/Contents/MacOS/Camino overlaps with __LINKEDIT segment (address =
0x10000 size = 0x1514) of @executable_path/libmozz.dylib

PBXCp build/Camino.app/Contents/MacOS/components/libcomposer.dylib
../dist/lib/components/libcomposer.dylib
    mkdir -p
/Users/sek/Documents/mozilla-current/camino/mozilla/camino/build/Camino.app/Contents/MacOS/components
    cd /Users/sek/Documents/mozilla-current/camino/mozilla/camino
    /Developer/Tools/pbxcp -exclude .DS_Store -exclude CVS -strip-debug-symbols
-resolve-src-symlinks
/Users/sek/Documents/mozilla-current/camino/mozilla/camino/../dist/lib/components/libcomposer.dylib
/Users/sek/Documents/mozilla-current/camino/mozilla/camino/build/Camino.app/Contents/MacOS/components

PBXCp build/Camino.app/Contents/MacOS/components/txmgr.xpt
../dist/bin/components/txmgr.xpt
    cd /Users/sek/Documents/mozilla-current/camino/mozilla/camino
    /Developer/Tools/pbxcp -exclude .DS_Store -exclude CVS -strip-debug-symbols
-resolve-src-symlinks
/Users/sek/Documents/mozilla-current/camino/mozilla/camino/../dist/bin/components/txmgr.xpt
/Users/sek/Documents/mozilla-current/camino/mozilla/camino/build/Camino.app/Contents/MacOS/components

PBXCp build/Camino.app/Contents/MacOS/components/composer.xpt
../dist/bin/components/composer.xpt
    cd /Users/sek/Documents/mozilla-current/camino/mozilla/camino
    /Developer/Tools/pbxcp -exclude .DS_Store -exclude CVS -strip-debug-symbols
-resolve-src-symlinks
/Users/sek/Documents/mozilla-current/camino/mozilla/camino/../dist/bin/components/composer.xpt
/Users/sek/Documents/mozilla-current/camino/mozilla/camino/build/Camino.app/Contents/MacOS/components

PBXCp build/Camino.app/Contents/MacOS/components/libtransformiix.dylib
../dist/lib/components/libtransformiix.dylib
(In reply to comment #0)
> When the dynamic link option is enable and build is done,
> the following files are copied to Camino.app/Contents/Resources
>  and Camino.app/Contents/MacOS/components. 
> 
>   -- libcomposer.dylib
>   -- txmgr.xpt
>   -- composer.xpt

Is the bug because of a duplicate copy ?
Summary: [Camino dynamic link build]: Some files are copied to Contents/Resources more than once. → [Camino dynamic link build]: Some files are copied to Contents/Resources more than once.
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Is the bug because of a duplicate copy ?

yes.

In 2005-03-12-08 offical build etc.,These files are extra copied onto
Contents/Resources.
And because official build was static build, the build method was not related. 
Summary: [Camino dynamic link build]: Some files are copied to Contents/Resources more than once. → Some files are copied to Contents/Resources more than once.
(Reporter)

Comment 3

14 years ago
In 20050403 NB, this problem did fix. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.