page won't stop loading when submit called a javascript function.

RESOLVED DUPLICATE of bug 81980

Status

()

defect
RESOLVED DUPLICATE of bug 81980
15 years ago
11 years ago

People

(Reporter: m.vanderlinden, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl-NL; rv:1.7.5) Gecko/20041202 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl-NL; rv:1.7.5) Gecko/20041202 Firefox/1.0

Source :

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html>
<head>
	<title>Untitled</title>
</head>

<body>

<script type="text/javascript">
function testRefresh()
{
	document.write( "testrefresh" )
	return ;
}
function testSubmit() 
{
	document.write( "testsubmit" )
	return ;
}
</script>

<form action="test.php" method="post" name="testform" id="testform">
<select name="animals" onChange="testRefresh();">
   <option value="cat">cat</option>
   <option value="cat">dog</option>
   <option value="cat">horse</option>
</select>

<input type="button" value="Test" onClick="testSubmit();">

</form>

</body>
</html>

Reproducible: Always

Steps to Reproduce:
1. Just load de page I submitted in the detail box.
2.
3.

Actual Results:  
Page won't stop loading!

Expected Results:  
Stop loading :-)

*** This bug has been marked as a duplicate of 81980 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.