Right-click context menus pop offscreen (15 items in list w/4 separators, 1024x768 res)

VERIFIED DUPLICATE of bug 245163

Status

()

Firefox
Menus
--
trivial
VERIFIED DUPLICATE of bug 245163
13 years ago
11 years ago

People

(Reporter: No Thanks, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

When right-clicking on an image in a thumbnail gallery, occasionally the context
menu will pop with the top command("Open Link In New Window") scolled off the
screen.  This usually happens when I right-click near the middle of the browser
window and the code gets confused as to pop the menu above the click or below
the click.  

I have two additional "Ad-Block" Entries in my right click menu.  I total, there
are 15 line items and 4 separators.  I am using a 1024x768 screen res in Win XP
SP2 w/non-classic GUI and "Extra Large Fonts" selected in Windows "Display"(in
case the height of my taskbar or titlebar is also a factor).

It took me a couple minutes to duplicate it with a SFW page, but if you had my
setup and right-clicked as high up on the "North America" image as you could,
then you would not be able to see "Open Link in New Window" at all.

I work tech support for an ISP and my coworker is constantly bitching about this
also.  He uses a community called myspace (ala friendster) which is a stable of
all manner of snotty bitches.

Anyways, just trying to help.  Keep up the good work.  We are almost to the
point where someone calls with a problem and before we even find out what OS
they are running, we have them install Firefox.

Reproducible: Always

Steps to Reproduce:
1.  GO TO LINK
2.  RIGHT-CLICK TOP OF "NORTH AMERICA" LINK
3.  BE USING 1024x768 + "EXTRA LARGE FONTS" in NON-CLASSIC WINDOWS XP

Actual Results:  
You jigger with the side-scroll bar and keep right-clicking until it pops with
the top item off-screen.

Expected Results:  
Instead of using the click point as the TOP or BOTTOM of the context menu, you
should have it figure out what how many items and separators it needs to display
in the list, figure out how much room it has to do it in, and pop the screen
accordingly.  The appropriate outcome would be right-clicking and it doesn't pop
"up and to the right" or "down and to the right", but just "somewhere to the
right" including the middle.

ed2k://|file|In%20Grid%20-%20Ah%20Lamour%20Lamour.mp3|5032787|4BABEC78582B10700456283F5A013852|/

*** This bug has been marked as a duplicate of 245163 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

11 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.