bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Mozilla does not print readonly fields while print preview works OK

RESOLVED DUPLICATE of bug 267352

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 267352
14 years ago
14 years ago

People

(Reporter: Jan Pernica, Unassigned)

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs-CZ; rv:1.7.5) Gecko/20041217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs-CZ; rv:1.7.5) Gecko/20041217

Our forms have readonly fields. Users wants to print the page, but readonly
fields are not printed - they are blank. Print preview shows correct values.

Reproducible: Always

Steps to Reproduce:
1.Open Page
2.Print Preview
3.Print

Actual Results:  
Readonly fields are printed blank

Expected Results:  
Readonly fields should contain values as on the screen.
(Reporter)

Updated

14 years ago
Version: unspecified → 1.7 Branch

Comment 1

14 years ago
I can NOT reproduce the problem with Mozilla 1.8b build 2005021505 under XP Pro.
I get the expected results accordingly.
(Reporter)

Comment 2

14 years ago
The problem is on Win XP with version 1.7.5. Which is latest version provided by
mozilla. With FireFox 1.0 it works fine.

Comment 3

14 years ago
FWIW, I also get the expected results with Netscape 7.2 which is rv: 1.7.2. You
may ask other people using specifically Mozilla rv:1.7.5. What is strange is
that Firefox 1.0's rv is 1.7.5 so it should print as well with Mozilla 1.7.5.
The problem does not seem to be limited to readonly fields. I can reproduce
it with a simple form containing text input fields and textareas.
The text entered in these areas is displayed in print preview but is missing
in the printout.

The problem is present in Mozilla Suite Release 1.7.5
and also in Mozilla Suite Pre-Release 1.7.6 Gecko/20050130.

It is not present Firefox 1.0, Mozilla Suite 1.7.2 and Mozilla Suite 1.8a6.

Comment 5

14 years ago
> The problem does not seem to be limited to readonly fields. I can reproduce
> it with a simple form containing text input fields and textareas.
> It is not present Firefox 1.0, Mozilla Suite 1.7.2 and Mozilla Suite 1.8a6.

I downloaded and installed Mozilla 1.7.5 and I see the bug now. After a search
(that we should all have done before filing|discussing this bug), I see that
this is a duplicate of bug 267352. Resolving as such.



*** This bug has been marked as a duplicate of 267352 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 6

14 years ago
As far as I can see/understand the issue, bug 267352 is not entirely fixed.
Comment #22 of bug 267352 says so.
You need to log in before you can comment on or make changes to this bug.