If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

ModPerl::PerlRun does not support "use constant" until CVS versions

RESOLVED WONTFIX

Status

()

Bugzilla
Bugzilla-General
RESOLVED WONTFIX
13 years ago
13 years ago

People

(Reporter: Max Kanat-Alexander, Assigned: Max Kanat-Alexander)

Tracking

Details

(URL)

(Assignee)

Description

13 years ago
ModPerl::PerlRun (which we want to use in bug 124591) does not work with "use
constant," because of a bug in PerlRun. This is fixed in PerlRun CVS as of
October 2004, but that's too recent of a version to require for Bugzilla to run
in PerlRun.

See the following post in a thread about the subject:

http://mathforum.org/epigone/modperl/whungdwyrdreh/4161FA10.6050005@stason.org

And a workaround that involves a small patch and a not-on-CPAN module:

http://mathforum.org/epigone/modperl/whungdwyrdreh/41671DE7.9050507@ectoplasm.org
(Assignee)

Comment 1

13 years ago
It's really not worth fixing this just to get PerlRun support.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.