Javascript function "prompt(string)" fail

RESOLVED DUPLICATE of bug 272455

Status

()

Core
DOM
--
major
RESOLVED DUPLICATE of bug 272455
13 years ago
13 years ago

People

(Reporter: flod, Assigned: jst)

Tracking

({regression})

1.0 Branch
x86
Windows XP
regression
Points:
---
Bug Flags:
blocking-aviary1.0.2 -
blocking-aviary1.0.3 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7.5) Gecko/20050214 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7.5) Gecko/20050214 Firefox/1.0

Javascript "prompt" function is not working on both these versions
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050214 Firefox/1.0+
Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7.5) Gecko/20050214 Firefox/1.0

I've got an extension that uses this function and Javascript console displays
this error:
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIDOMJSWindow.prompt]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://bbcodextra/content/bbcodextra.js :: anonymous :: line 190"  data: no]

I've already verified this problem on clean install and new profile


Reproducible: Always
(Reporter)

Comment 1

13 years ago
I just forgot to say that I've already found this bug 
https://bugzilla.mozilla.org/show_bug.cgi?id=272455
I think it's the same problem even if this bug is compiled for TB
Summary: Javascript prompt fail → Javascript function "prompt(string)" fail

Comment 2

13 years ago
Confirmed on Firefox 1.0.1 Windows XP.
This should have been a show-stopper for the 1.0.1 release, as it breaks many
extensions.

Comment 3

13 years ago
Same problem here, starting on 1.0.1 (1.0 works fine), tested on OSX 1.0.1,
WinXP 1.0.1 and 1.0+ from today with clean profile.  

Easiest way to reproduce is Tools.. Javascript Console.. type:

prompt("a");

on the line, click evaluate, see error message.

Comment 4

13 years ago
(In reply to comment #2)
> Confirmed on Firefox 1.0.1 Windows XP.
> This should have been a show-stopper for the 1.0.1 release, as it breaks many
> extensions.

It is a show-stopper in deed. We have an extension for our English-Hungarian
dictionary and several user reported that the extension is broken as it doesn't
display a prompt for entering a word if no word is selected in the page. See:

http://szotar.sztaki.hu/docs/kozepsoujj/mozilla/sztakidict_0.2.xpi

Updated

13 years ago
Flags: blocking-aviary1.1?
Keywords: regression

Updated

13 years ago
Flags: blocking-aviary1.0.2?
Component: General → DOM
Product: Firefox → Core
Version: unspecified → 1.0 Branch
Assignee: firefox → general
QA Contact: general → ian
Assignee: general → jst
Flags: blocking-aviary1.0.2?
(Assignee)

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 272455 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Flags: blocking-aviary1.1?
minusing dupe
Flags: blocking-aviary1.0.3?
Flags: blocking-aviary1.0.3-
Flags: blocking-aviary1.0.2?
Flags: blocking-aviary1.0.2-
You need to log in before you can comment on or make changes to this bug.