Closed Bug 282402 Opened 17 years ago Closed 17 years ago

Drag and Drop of a message in compose windows should attach the mail to the message

Categories

(Thunderbird :: Message Compose Window, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 113435

People

(Reporter: pvdharanjm, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

o click File->New->Message : this will open compose window
o Goto mail window
o drag a message from the list and drop it on the compose window
o The dropped message should be attached to the new message. 
o Currently this feature is not supported. Outlook supports it and it is very handy.


Reproducible: Always

Steps to Reproduce:
o click File->New->Message : this will open compose window
o Goto mail window
o drag a message from the list and drop it on the compose window
o The dropped message should be attached to the new message. 
o Currently this feature is not supported. Outlook supports it and it is very handy.
It should work if you dnd the message over the attachment panel in the composer
window (at least for Mailnews).
In TB, the attachment pane is not displayed until an attachment is actually seen 
-- but you can still drag the message (or a file) over the recipient headers, 
and the attachment panel will automagically display; you can drop it there.

For HTML compose, it is possible to drop a file (but not a message) into the 
compose body, but the results are not necessarily what you might expect.  For 
plain-text compose, the message body does not accept drops of any sort.  It's 
not clear which mode reporter is using, but I'm duping to the most likely 
candidate.

*** This bug has been marked as a duplicate of 113435 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.