Closed Bug 282422 Opened 16 years ago Closed 16 years ago

XIM over-the-spot patch

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 271815

People

(Reporter: tetralet, Assigned: bugzilla)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; zh-TW; rv:1.7.5) Gecko/20050215 Firefox/1.0 (Debian package 1.0+dfsg.1-6.overthespot)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; zh-TW; rv:1.7.5) Gecko/20050215 Firefox/1.0 (Debian package 1.0+dfsg.1-6.overthespot)

Hi,

The OverTheSpot mode of XIM is the most common input method for Chinese/Japanese
users,
but it is a pity that gtk2+ library don't support it.

There is a patch written by Edward Liu <cp76@csie.nctu.edu.tw> could make gtk2+
library to support Over TheSpot mode.
Please visit http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=290469 and
http://bugzilla.gnome.org/show_bug.cgi?id=158678 for more details.

But mozilla/mozilla-firefox/mozilla-thunderbird still need more patches to make
its supporting OverTheSpot mode.
The attached file is the patch for mozilla-firefox and mozilla-thunderbird.
This patch is very similarity to the patch in
https://bugzilla.mozilla.org/show_bug.cgi?id=271815, but it is fit to firefox
and thunderbird.

BTW,
Some input method, like scim and gcin, uses it's own gtk im module so that it
can support overthesopt input method without patching libgtk2.0-0 package.
Therefore, I think it is ok that firefox could apply this patch without
libgtk2.0-0 package accepted the patch first.

After some testing, we feel that this patch is stable enough to update to the
upstream.
Please consider to apply this.

Thanks.


Reproducible: Always

Steps to Reproduce:

*** This bug has been marked as a duplicate of 271815 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.