Closed Bug 282468 Opened 17 years ago Closed 11 years ago

false innerWidth/innerHeight values

Categories

(Core :: DOM: CSS Object Model, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 204743

People

(Reporter: szabo.daniel, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

window.innerWidth and innerHeight return false values when the browser window is
smaller than a specific size. Their minimum values are 216 and 150 respectively.
In these cases outerWidth and outerHeight values will be smaller then the
inner... values, which is nonsense.

Reproducible: Always

Steps to Reproduce:
Open the attached html file, that will display the inner... and outer... values.
Resize the browser as small as you can.
Press F5.

Actual Results:  
inner=216x150, outer=112x157

Expected Results:  
inner measures should be less than outer measures
i.e. inner=108x30, outer=112x157

*** This bug has been marked as a duplicate of 147521 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Resolution: DUPLICATE → INCOMPLETE
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
This bug should be fixed in Firefox 2. Can you please say whether you are still seeing this issue in Firefox 2?
This bug still exists (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4)

Just open the attachment in a new window, resize it and press F5.
innerHeight seems to be working now, but innerWidth still contains some arbitary (but fixed) value (in my case it is 537). In Firefox 1.5.0.5 it displays 650.
(In reply to comment #4)
> This bug still exists (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB;
> rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4)
> 
> Just open the attachment in a new window, resize it and press F5.
> innerHeight seems to be working now, but innerWidth still contains some
> arbitary (but fixed) value (in my case it is 537). In Firefox 1.5.0.5 it
> displays 650.
> 

This bug was resolved as WORKSFORME because it no longer exists in the current trunk builds.  The bug status has to do with if the bug exists on the current trunk, not the latest release.  Your testcase works in the Firefox 3.0 alpha builds and therefor will work in Firefox 3.0.  WORKSFORME is the correct resolution because we do not know which specific checkin fixed your issue.  It does not mean we don't believe the issue ever existed.
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 147521
It was resolved as WORKSFORME almost 2.5 years ago (Feb. 2005), long before FF2's first release. Actually, it should have been resolved in FF1.5 then. So I'll check if it still exists in another 2.5 years.
As of today using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 this bug still exists.
innerHeight is ok. innerWidth is some arbitrary value (in my case, 403)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Version: unspecified → 1.0 Branch
As you can see in the comment just before yours this bug existed in 3.0.5 as well.
And I just checked it on

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2

Both versions FAIL the test: innerHeight is ok, innerWidth is some arbitrary value

Come on folks. Is it really that hard to click on that attachment instead of writing 5 lines of comment??
OS: Windows 2000 → Windows XP
Version: 1.0 Branch → 3.6 Branch
The test appears to WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ID:20101203075014

My Values:
Full size-
inner=1920x985 outer=1928x1178
Resize window to 800x600-
inner=792x407 outer=800x600

Reporter -> Can you confirm that this issue is resolved, or point out where my values are incorrect?
(In reply to comment #10)
> The test appears to WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ID:20101203075014
> 
> My Values:
> Full size-
> inner=1920x985 outer=1928x1178
> Resize window to 800x600-
> inner=792x407 outer=800x600
> 
> Reporter -> Can you confirm that this issue is resolved, or point out where my
> values are incorrect?

If I make the window small enough, I can get Inner=497x278 outer=254x368.

This is with the current trunk build, so this is not fixed.

Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b9pre) Gecko/20101222 Firefox/4.0b9pre ID:20101222030351
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: bugzilla → nobody
Component: General → DOM
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → general
Hardware: x86 → All
Version: 3.6 Branch → Trunk
Component: DOM → Embedding: APIs
QA Contact: general → apis
Bill, any reason you put this bug in Embedding: APIs?
Component: Embedding: APIs → DOM: CSS Object Model
QA Contact: apis → style-system
Probably the wrong place.  It is clearly a core bug and not a firefox bug.  I found a previous bug about issues with inner width and height and it was filed on this component.
Status: NEW → RESOLVED
Closed: 15 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 204743
This is the same issue as bug 204743.  This all breaks when you make the window narrower than what is required to show all the elements in the urlbar.  The first symptom is that the vertical scrollbar disappears.

Removing items form the urlbar changes the width at which the issue appears, so this is the same as bug 204743.
You need to log in before you can comment on or make changes to this bug.