Download Mgr doesn't report insufficient space on target drive - just stops

RESOLVED DUPLICATE of bug 257812

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED DUPLICATE of bug 257812
14 years ago
10 years ago

People

(Reporter: hap, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

This bug report comment is similar to Bug ID# 257812 (similar - not the same).

When downloading a file which is larger than the remaining space on the target
drive, the Firefox 1.0 Download Manager simply stops when drive space runs out.
 It doesn't seem to lock up.  The Download Manager window doesn't close.  There
are no special messages displayed about insufficient drive space and the
download progress indicator doesn't read "Pause" or "Stopped" or "Done" or
"Complete" or "Terminated" or any other kind of message.  It appears to continue
to try downloading but the percentage complete doesn't change and there's no
effort to post any kind of message to indicate what's holding up the download.

To be fair, this first occured to me when using the Download Manager Tweak
extension (v.0.6.3).  Since I don't want to lose what I've typed here, I'll have
to uninstall the extension and see if it does the same thing.  I hope to be able
to amend this bug report later.

Reproducible: Always

Steps to Reproduce:
1. Check how much drive space you have.
2. Download a file that's larger than the available drive space.
3.

Actual Results:  
Download Manager window stays open and download doesn't progress beyond the
percentage it stopped at... however, it's not locked up and can still be cancelled.

Expected Results:  
It would be best if the FireFox Download Manager posted an insufficient drive
space message as soon as the download is initiated, NOT after the download has
progressed for a while and drive space reaches zero.  It would also be great if
the download remained listed in the Download Manager but PAUSED until drive
space was made available.  At that time, FireFox could display a message
(perhaps in a slider like the one that reports concluded downloads) that reminds
the user that there is a pending & incomplete download and then asks whether to
a) Start/resume download, b) Hold download until later, c) Cancel download.

Although I doubt if it's relevent, at the time, I was using the Silver Skin
2.6.3 Theme, and had the following extensions installed:
- Tabbrowser Preferences 1.2.2
- MR Tech's Local Install 1.2.5
- Download Manager Tweak 0.6.3 (possibly related)
- OpenBook 1.2.0
- FLST 0.8.1
- DictionarySeacrh 0.7
- Bandwidth Tester 0.4.1
- Copy Plain Text 0.2.1
- Forecast Fox 0.5.9
- ieview 0.86
- SmoothWheel 0.43.1.20041107
- xMirror 0.1.1

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 257812 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
bug 257812 seems to be more about making the temp-dir a pref, not the general
problem Firefox has with full drives. Should this bug be reopened?
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.