Calendar HTML Export functionality missing

RESOLVED FIXED

Status

Calendar
General
--
enhancement
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: José Luis Tallón, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050110 Firefox/1.0 (Debian package 1.0+dfsg.1-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050110 Firefox/1.0 (Debian package 1.0+dfsg.1-2)

It should be very to export to HTML: simply save a dump of the HTML which is
already being generated by Calendar: instead of rendering it in Gecko, save it to a
file... 

Ideally, the output would be split among several pages (one per month), linked
by means of REL="prev" / REL="next" tags.

Of Course, the period to export should be selectable, and there should be a
button  available to select *all events* in the calendar with one click. This
way, exporting a whole Calendar would be a matter of five clicks at most (start
Export Wizard, select HTML output format, select "all events" option, select
output file, click Finish)
[sorry, too busy with many other OSS projects to devote time to yet another one :-S]

Reproducible: Always

Steps to Reproduce:
(Command not available)
Actual Results:  
(None)

Expected Results:  
Produce HTML output

Even though ICS can be shared over HTTP, for users who do not have ICS clients,
it is very important that we can publish Calendars in HTML format, so that they
look at them from a browser.

Filed under "Normal" bug report as opposed to "Wishlist", because this feature
would really make SunBird competitive in front of the competition.
(In reply to comment #0)
> It should be very to export to HTML: simply save a dump of the HTML which is
> already being generated by Calendar: instead of rendering it in Gecko, save it
to a
> file... 

What makes you think html is already generated? It's all xul.

> Filed under "Normal" bug report as opposed to "Wishlist", because this feature
> would really make SunBird competitive in front of the competition.

Still, it is an enhanchment.
Severity: normal → enhancement

Comment 2

14 years ago
mvl, we already generate HTML output for printing purposes. Couldn't this just
be reused to fix this bug?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

13 years ago
Duplicate of bug 155237?

Comment 4

13 years ago
HTML export is now available, thanks to bug 298772.  Resolving as fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.